Ask Your Question
0

Clarification on docs for self service connectivity

asked 2016-01-08 00:52:00 -0600

vincent gravatar image

updated 2016-01-26 12:45:27 -0600

rbowen gravatar image

I followed the install guide for Liberty on CentOS to the letter and can boot an instance on a self-service network, but I can _not_ communicate with that instance (other than directly through its netns on the compute node itself).

Looking at the self-service connectivity diagram at

http://docs.openstack.org/liberty/ins...

I traced over the network connectivity and all interfaces I see in my setup match the one in the docs with one EXCEPTION... what I do not see is the qg to public-bridge port tap pair going from the qrouter namespace, in my case my qrouter namespace shows only the private vNIC interface that is connected to the private bridge (see http://paste.openstack.org/show/483298/), so my public and private networks are essentially isolated.

Can you shed some light on what may be going on?

None of the neutron logs show relevant issues. I have also tried creating the veth pair manually and inserting them but somehow it didn't seem to be sufficient to route the traffic from the public to private nets.

I'm also attaching the output of iptables -L -t nat on the controller node as well as against the router namespace http://paste.openstack.org/show/483299/), I'd be happy to provide more details as this has been bugging me for some time now.

Thanks!

edit retag flag offensive close merge delete

Comments

Update: Oddly enough I can get connectivity if I create a unicast vxlan channel between the controller and compute node, which leads me to think that the connectivity issue I encountered was with the obscure l2population and vxlan drivers, does anyone have any insights on how the vxlan net is setup

vincent gravatar imagevincent ( 2016-01-18 21:33:42 -0600 )edit

I think l2pop is still not generally recommended for usage. Do you have a very specific need to enable the driver? If not, you may be better off avoiding it.

ihar-hrachyshka gravatar imageihar-hrachyshka ( 2016-03-29 07:02:43 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-03-31 01:52:17 -0600

I think you might be missing adding router to external network i.e neutron router-gateway-set router public

Then you have to create a floatingip for your vm and should try to connect from host to vm through floatingip. If you want to connect to vm without floating ip(through vm's private ip and without ip netns), then you need to have a route like below in your host

sudo ip route

172.16.1.0/24 via 172.24.4.2 dev br-ex

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2016-01-08 00:52:00 -0600

Seen: 116 times

Last updated: Jan 26 '16