After Kilo to Liberty upgrade, VM is not getting the IP from DHCP agnet!

asked 2016-01-07 00:50:13 -0600

Vinoth gravatar image

updated 2016-01-07 00:57:16 -0600


I tried upgrading Openstack release from KIlo version to Liberty virsion in my test environment (VirtualBox). The setup is all-in-one without any HA configured.

I followed the below steps during the upgrading process:

1) Removed the repository for the previous release packages (Removed Kilo Repo)
2) Changed the repository for the new release packages (Changed to Liberty Repo)
3) Backed up all the mysql DB and Kilo configuration file.
4) Ran "apt-get dist-upgrade" to upgrade all the package.
5) Configured all the new configuration files for Liberty version.
6) Ran " DB sync for all the OpenStack service" which has modified the DB tables for Liberty release with existing data.
7) Restarted all the services. All seems working fine. 
8) Launched the new VM / started the existing VM using the horizon dashboard which turned Active state and running.

Now, the problem is my both the VM is not getting the IP address from DHCP agent :-(

I configured my kilo release using OpenVswitch agent in ml2_conf.ini file. So after upgrading also I used the same agent even though the Liberty document used Linux-bridge-agent in ml2_conf.ini. Is there any chance that this could be the reason?

Kindly, Assist me with some suggestions.

Thanks in Advance.


edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2016-02-12 13:50:11 -0600

tictoc gravatar image

Did you every or anyone else get an upgrade from Kilo to Liberty all in one server to work? Any links or other steps needed?

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-01-07 00:50:13 -0600

Seen: 1,197 times

Last updated: Feb 12 '16