Ask Your Question
0

cinder seems to timeout on large volume creation?

asked 2016-01-06 15:14:51 -0600

upon creating a volume out of a vmdk image of 50 gb and allocating a 300gb volume to the image, gluster give this mesage:

Do i need to adjust the timeouts or something?

2016-01-06 16:10:30.077 1407 ERROR cinder.scheduler.flows.create_volume [req-aabab94a-8a8a-44fd-ad9c-c4f35f9f19c3 63c9ca9aeae9424a9184b44c20db1d04 3ed162e2b9bd48978590e10c65c02628 - - -] Failed to run task cinder.scheduler.flows.create_volume.ScheduleCreateVolumeTask;volume:create: No valid host was found. Exceeded max scheduling attempts 3 for volume None
2016-01-06 16:10:30.079 1407 DEBUG cinder.volume.flows.common [req-aabab94a-8a8a-44fd-ad9c-c4f35f9f19c3 63c9ca9aeae9424a9184b44c20db1d04 3ed162e2b9bd48978590e10c65c02628 - - -] Updating volume: 5cf7e414-b809-428e-b3be-e5884d6415de with {'status': 'error'} due to: No valid host was found. Exceeded max scheduling attempts 3 for volume None _update_object /usr/lib/python2.7/site-packages/cinder/volume/flows/common.py:87
2016-01-06 16:10:30.123 1407 DEBUG cinder.scheduler.manager [req-aabab94a-8a8a-44fd-ad9c-c4f35f9f19c3 63c9ca9aeae9424a9184b44c20db1d04 3ed162e2b9bd48978590e10c65c02628 - - -] Task 'cinder.scheduler.flows.create_volume.ScheduleCreateVolumeTask;volume:create' (5eb70764-fce1-4f77-a054-302c0b920e05) transitioned into state 'SUCCESS' from state 'RUNNING' with result 'None' _task_receiver /usr/lib/python2.7/site-packages/taskflow/listeners/logging.py:178
2016-01-06 16:10:30.124 1407 DEBUG cinder.scheduler.manager [req-aabab94a-8a8a-44fd-ad9c-c4f35f9f19c3 63c9ca9aeae9424a9184b44c20db1d04 3ed162e2b9bd48978590e10c65c02628 - - -] Flow 'volume_create_scheduler' (8f99c2c2-8580-451d-be92-14fb85a78ff5) transitioned into state 'SUCCESS' from state 'RUNNING' _flow_receiver /usr/lib/python2.7/site-packages/taskflow/listeners/logging.py:151
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-09-14 12:08:29 -0600

updated 2016-09-14 12:16:21 -0600

setting session timeout in horizon and keystone token lifetime seemed to help. (mitaka)

in /etc/openstack-dashboard/local_settings:

SESSION_TIMEOUT = 86400

and in /etc/keystone/keystone.conf

[token]
expiration = 86400
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-01-06 15:14:51 -0600

Seen: 733 times

Last updated: Sep 14 '16