Ask Your Question
0

ERROR: openstackclient.shell Exception raised: (pbr 0.11.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=1.6')

asked 2016-01-05 11:18:00 -0500

anonymous user

Anonymous

I am installing Manila on Ubuntu 14.04. I am following this: http://docs.openstack.org/developer/manila/adminref/quick_start.html (http://docs.openstack.org/developer/m...) and have set up keystone using http://docs.openstack.org/kilo/install-guide/install/apt/content/ch_keystone.html (http://docs.openstack.org/kilo/instal...). I am very new to OpenStack community. Any help would be really appreciated. I created user in openstack for Manila. After that I executed following set of commands : git clone -b stable/kilo https://github.com/openstack/manila sudo python setup.py install sudo pip install python-manilaclient>=1.0.4 When I create new role / add user I get error : ERROR: openstackclient.shell Exception raised: (pbr 0.11.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=1.6'), set(['python-keystoneclient', 'stevedore', 'oslo.utils']))

After reading existing threads on similar issue. I executed : pip install --upgrade setuptools However, the problem still exists.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2016-01-06 00:56:02 -0500

Bharath gravatar image

Hi,

For Manila to be successfully installed it is required for several other python packages to be in place prior.

https://github.com/openstack/manila/b... - suggests that pbr version installed on system should be >=1.6. I could see from the logs that version of pbr on your system is 0.11.0. (Confirm that using "pip list | grep pbr)

If there is a version mismatch follow the below steps:

pip uninstall pbr

pip install pbr==1.6.1

Check the version again using pip list and continue with manila installation.

edit flag offensive delete link more

Comments

I get this error :
ERROR: openstackclient.shell Exception raised: (pbr 1.6.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr!=0.7,<1.0,>=0.6'), set(['oslo.i18n', 'python-novaclient', 'oslo.utils', 'oslo.config', 'python-neutronclient', 'oslo.serialization', 'py

user123 gravatar imageuser123 ( 2016-01-12 18:40:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-01-05 11:18:00 -0500

Seen: 945 times

Last updated: Jan 06 '16