Ask Your Question
0

Centos 7 Horizon 500 mod_wsgi errors

asked 2015-12-31 21:01:30 -0500

Kernel_Panic gravatar image

I'm following the RHEL 7 guide for my first openstack installation. Everything is working really well with very few surprises, so props to the OP of this excellent guide!

When I installed and test Horizon I get a 500 error and the following apache logs. This looks to be a django environment issue with paths or permissions. It cant find the middleware modules. I've tried to find the path variable in the django configs but I cant figure it out. Could I get some hints on where to look next? This appears to be a pretty common issue with app builds, but this is the red hat horizon package itself.

HTTPD Logs:

[Thu Dec 31 20:01:50.288040 2015] [:error] [pid 5985] [remote 10.0.100.12:244] mod_wsgi (pid=5985): Exception occurred processing WSGI script '/usr/share/openstack-dashboard/openstack_dashboard/wsgi/django.wsgi'. [Thu Dec 31 20:01:50.288116 2015] [:error] [pid 5985] [remote 10.0.100.12:244] Traceback (most recent call last): [Thu Dec 31 20:01:50.288139 2015] [:error] [pid 5985] [remote 10.0.100.12:244] File "/usr/lib/python2.7/site-packages/django/core/handlers/wsgi.py", line 187, in __call__ [Thu Dec 31 20:01:50.288238 2015] [:error] [pid 5985] [remote 10.0.100.12:244] self.load_middleware() [Thu Dec 31 20:01:50.288253 2015] [:error] [pid 5985] [remote 10.0.100.12:244] File "/usr/lib/python2.7/site-packages/django/core/handlers/base.py", line 44, in load_middleware [Thu Dec 31 20:01:50.288367 2015] [:error] [pid 5985] [remote 10.0.100.12:244] for middleware_path in settings.MIDDLEWARE_CLASSES: [Thu Dec 31 20:01:50.288379 2015] [:error] [pid 5985] [remote 10.0.100.12:244] File "/usr/lib/python2.7/site-packages/django/conf/__init__.py", line 54, in __getattr__ [Thu Dec 31 20:01:50.288460 2015] [:error] [pid 5985] [remote 10.0.100.12:244] self._setup(name) [Thu Dec 31 20:01:50.288473 2015] [:error] [pid 5985] [remote 10.0.100.12:244] File "/usr/lib/python2.7/site-packages/django/conf/__init__.py", line 49, in _set up [Thu Dec 31 20:01:50.288493 2015] [:error] [pid 5985] [remote 10.0.100.12:244] self._wrapped = Settings(settings_module) [Thu Dec 31 20:01:50.288504 2015] [:error] [pid 5985] [remote 10.0.100.12:244] File "/usr/lib/python2.7/site-packages/django/conf/__init__.py", line 128, in __init__ [Thu Dec 31 20:01:50.288523 2015] [:error] [pid 5985] [remote 10.0.100.12:244] mod = importlib.import_module(self.SETTINGS_MODULE) [Thu Dec 31 20:01:50.288534 2015] [:error] [pid 5985] [remote 10.0.100.12:244] File "/usr/lib/python2.7/site-packages/django/utils/importlib.py", line 40, in import_module [Thu Dec 31 20:01:50.288582 2015] [:error] [pid 5985] [remote 10.0.100.12:244] __import__(name) [Thu Dec 31 20:01:50.288594 2015] [:error] [pid 5985] [remote 10.0.100.12:244] File "/usr/share ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-12-31 21:27:24 -0500

Kernel_Panic gravatar image

It was the TIME_ZONE + variable in /etc/openstack-dashboard/local_settings file I commented it out and viola!

edit flag offensive delete link more

Comments

You removed the time_zone option and worked?

AmirV gravatar imageAmirV ( 2016-12-24 18:39:31 -0500 )edit

Same issue here. Commenting TIME_ZONE out, and restarting apache, did not fix it. Any other ideas?

jmguzman gravatar imagejmguzman ( 2017-04-17 17:35:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-12-31 20:58:38 -0500

Seen: 241 times

Last updated: Dec 31 '15