Error finding address for http://10.112.116.246:9292/versions

asked 2015-12-28 02:50:43 -0600

bomin gravatar image

I'm trying to create an image using glance API, and here's my command

glance image-create --name precise-x86_64 --visibility True --disk-format qcow2 --container-format bare --file precise-server-cloudimg-amd64-disk1.img --progress

After running the command, I got below error

Error finding address for http://10.112.116.246:9292/versions: HTTPConnectionPool(host='10.112.116.246', port=9292): Max retries exceeded with url: /versions (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f6e90d6e710>: Failed to establish a new connection: [Errno 111] Connection refused',))

10.112.116.246 is the VM IP, and it looks like it's because 'versions' is not correctly replaced? Where can I set it?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-12-28 03:08:41 -0600

Prateek K gravatar image

9292 is the port at which glance api listen's the request for all glance related operations...

Do a keystone enpoint-list -- This will give you the list of endpoints configured... Set it correctly and point to the IP where the glance api service is running... Probably your controller... Also check weather your glance-api is actually running or not

edit flag offensive delete link more

Comments

ah... where to set it then? How can I tell if glance-api is running? Sorry, new to Openstack...

bomin gravatar imagebomin ( 2015-12-28 03:29:36 -0600 )edit

If you are talking about a normal openstack multi-node installation it should be on controller node... Do a netstat -anp |grep 9292 this will give you the process which is listening to this port .. See that process if it's running fine. Do paste the logs as well of glance api

Prateek K gravatar imagePrateek K ( 2015-12-28 03:35:57 -0600 )edit

Thanks. The service is not running, and after I run "glance-api", I added the image. However, the weird thing is, why I can't see it in horizon? Here's the URL, http://10.112.116.246/dashboard/admin/images/. I'm using OS_NAME as admin. By the way, it's the devstack that I'm using.

bomin gravatar imagebomin ( 2015-12-28 03:56:11 -0600 )edit

Okay finally glance-api is running and the image is added. Now we need to see which user is used to create the image ... Is is admin or demo... you must be using source openrc admin admin in terminal and creating image .. on the top in horizon the tenant would be demo change it to admin..

Prateek K gravatar imagePrateek K ( 2015-12-28 04:20:07 -0600 )edit

or add --public true in the cli as a parameter in the glance image-create command and then it will be visible to all

Prateek K gravatar imagePrateek K ( 2015-12-28 04:20:50 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-12-28 02:50:43 -0600

Seen: 6,570 times

Last updated: Dec 28 '15