Ask Your Question
0

nova service-list Error : Unknown Error (HTTP 503)Service Unavailable: The server is currently unavailable. Please try again at a later time, while nova-manage service list command shows all the services running fine. [closed]

asked 2015-12-22 10:58:33 -0500

pjb gravatar image

updated 2015-12-23 09:59:16 -0500

Hi, I am trying to install OpenStack Liberty controller node on CentOS 7.1, running as a VM. I have followed the official guide, step-by-step(cross verified multiple times). While commands related to neutron works file, but for glance and nova, I am getting error.(log file details below). Please note that "nova-manage service list" command show all the services up and running.

  • LOG file details:

$tail /var/log/nova/nova-api.log

2015-12-23 10:43:17.290 2916 INFO nova.metadata.wsgi.server [-] (2916) wsgi starting up on http://0.0.0.0:8775/
2015-12-23 10:43:17.289 962 INFO oslo_service.service [-] Started child 2917
2015-12-23 10:43:17.294 2917 INFO nova.metadata.wsgi.server [-] (2917) wsgi starting up on http://0.0.0.0:8775/
2015-12-22 10:57:28.544 11648 INFO nova.osapi_compute.wsgi.server [-] 10.91.208.81 "GET /v2/44ef15c8b0e84c48a4acffea0911d394/os-agents HTTP/1.1" status: 503 len: 323 time: 0.1808271
2015-12-22 11:26:03.869 11647 WARNING keystonemiddleware.auth_token [-] Identity response: {"error": {"message": "The request you have made requires authentication.", "code": 401, "title": "Unauthorized"}}
2015-12-22 11:26:03.932 11647 WARNING keystonemiddleware.auth_token [-] Identity response: {"error": {"message": "The request you have made requires authentication.", "code": 401, "title": "Unauthorized"}}
2015-12-22 11:26:03.932 11647 CRITICAL keystonemiddleware.auth_token [-] Unable to validate token: Identity server rejected authorization necessary to fetch token data
2015-12-22 11:26:03.932 11647 INFO nova.osapi_compute.wsgi.server [-] 10.91.208.81 "GET /v2/ HTTP/1.1" status: 503 len: 323 time: 0.0933290

$tail /var/log/glance/api.log

2015-12-22 11:46:53.650 10901 WARNING keystonemiddleware.auth_token [-] Identity response: {"error": {"message": "The request you have made requires authentication.", "code": 401, "title": "Unauthorized"}}
2015-12-22 11:46:53.678 10901 WARNING keystonemiddleware.auth_token [-] Identity response: {"error": {"message": "The request you have made requires authentication.", "code": 401, "title": "Unauthorized"}}
2015-12-22 11:46:53.678 10901 CRITICAL keystonemiddleware.auth_token [-] Unable to validate token: Identity server rejected authorization necessary to fetch token data
2015-12-22 11:46:53.680 10901 INFO eventlet.wsgi.server [-] 10.91.208.81 - - [22/Dec/2015 11:46:53] "GET /v2/images?limit=20&sort_key=name&sort_dir=asc HTTP/1.1" 503 370 0.076165

/etc/nova/nova.conf details

auth_uri = http://controller:5000
auth_url = http://controller:35357
auth_plugin = password
project_domain_id = default
user_domain_id = default
project_name = service
username = nova
password = Service123
[database]
connection = mysql://nova:Service123@controller/nova
[vnc]
vncserver_listen=controller
vncserver_proxyclient_address=controller

admin-openrc.sh details

export OS_PROJECT_DOMAIN_ID=default
export OS_USER_DOMAIN_ID=default
export OS_PROJECT_NAME=admin
export OS_TENANT_NAME=admin
export OS_USERNAME=admin
export OS_PASSWORD=password
export OS_AUTH_URL=http://controller:35357/v3
export OS_IDENTITY_API_VERSION=3
export OS_IMAGE_API_VERSION=2

Any help will be great(stuck here since four days). Please feel free to ask for any more details.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by pjb
close date 2016-02-05 07:29:28.702495

Comments

Check the details for keystone_authtoken in the config files. There should be a missmatch or error like identity version, identity_url, etc

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-12-23 08:41:41 -0500 )edit

Hi.. thanks for the response. I have updated the question. Please note that for neutron, I was getting the same error. What I did to get it away for neutron was, I changed the config file order in the /usr/lib/systemd/system/neutron-server.service, giving /etc/neutron/neutron.conf as the first.

pjb gravatar imagepjb ( 2015-12-23 09:53:31 -0500 )edit

Neutron should start once rabbitmq has started, if not, neutron will not start. Can you restart rabbitmq server, then keystone and neutron server. Check if that works

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-12-23 11:46:48 -0500 )edit

Restarted the services as you mentioned. Neutron server starts fine, but Neutron command doesn't run.(These happens only when I set the config file order as the default, for neutron).

pjb gravatar imagepjb ( 2015-12-24 00:11:40 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
1

answered 2015-12-23 10:54:44 -0500

Tony gravatar image

updated 2015-12-23 22:29:14 -0500

Bipin gravatar image

Can you try the following cURL command and let me know if it is successful?

curl -i \
  -H "Content-Type: application/json" \
  -d '
{
    "auth": {
        "identity": {
            "methods": [
                "password"
            ],
            "password": {
                "user": {
                    "name": "nova",
                    "domain": {
                        "id": "default"
                    },
                    "password": "Service123"
                }
            }
        }
    }
}' \
  http://controller:5000/v3/auth/tokens; echo
edit flag offensive delete link more

Comments

Hi, I ran the above command. It gives the following error. Part 1/2

HTTP/1.1 401 Unauthorized
Date: Thu, 24 Dec 2015 06:12:03 GMT
Server: Apache/2.4.6 (CentOS) mod_wsgi/3.4 Python/2.7.5
Vary: X-Auth-Token
x-openstack-request-id: req-2354b101-d873-49ce-9623-1b45ee359801
pjb gravatar imagepjb ( 2015-12-24 00:14:41 -0500 )edit

part 2/2

WWW-Authenticate: Keystone uri="http://controller:5000"
Content-Length: 114
Content-Type: application/json

{"error": {"message": "The request you have made requires authentication.", "code": 401, "title": "Unauthorized"}}
pjb gravatar imagepjb ( 2015-12-24 00:15:13 -0500 )edit

Also if I give the admin password in the above curl command. Response is : Part 1/2

HTTP/1.1 201 Created
Date: Thu, 24 Dec 2015 06:25:31 GMT
Server: Apache/2.4.6 (CentOS) mod_wsgi/3.4 Python/2.7.5
X-Subject-Token: c7b82dd164264a8e8812de521d64af3c
Vary: X-Auth-Token
pjb gravatar imagepjb ( 2015-12-24 00:31:45 -0500 )edit

Part 2/2

x-openstack-request-id: req-129f09b7-0bda-49ec-bb36-521f29b087cc
Content-Length: 296
Content-Type: application/json
{"token": {"methods": ["password"], "expires_at": "2015-12-24T07:25:32.507202Z", "extras": {}, "user": {"domain": {"id": "default", "name": "Default"}
pjb gravatar imagepjb ( 2015-12-24 00:36:11 -0500 )edit

part 3/3

, "id": "f09b15a1a6894051a42a5446599c7e3e", "name": "nova"}, "audit_ids": ["sPI4VuM_TNWYZIEO6c23kA"], "issued_at": "2015-12-24T06:35:25.617232Z"}}
pjb gravatar imagepjb ( 2015-12-24 00:36:49 -0500 )edit
0

answered 2015-12-24 02:31:58 -0500

pjb gravatar image

HI, I finally found out the error. The issue was, while creating the service(glance, neutron, nova) using the openstack command, I was giving the password as admin password($ADMIN_PWD). While in the conf files and the database of each service , the service password($SERVICE_PWD) was different. So I re-installed the whole set-up using the right configuration.(use ADMIN_PWD only while creating the admin user and for the admin-openrc.sh file).

edit flag offensive delete link more
0

answered 2016-01-15 21:33:00 -0500

Kernel_Panic gravatar image

I went back and deleted the nova user and recreated it with using the nova password that nova started working on the controller node. I must have put in the admin password.. My Bad! :-/

openstack user create --domain default --password-prompt nova User Password: $NOVA_PASSWORD Repeat User Password: $NOVA_PASSWORD

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-12-22 10:58:33 -0500

Seen: 11,480 times

Last updated: Jan 15 '16