Ask Your Question

No handlers could be found for logger "oslo_config.cfg"

asked 2015-12-21 01:24:35 -0500

NileshB gravatar image

updated 2015-12-28 11:51:12 -0500

smaffulli gravatar image

I am installing Openstack Liberty by following Openstack guide on Ubuntu 14.04 LTS. I followed all steps, then issue following command for populating identity database.

#su -s /bin/sh -c "keystone-manage db_sync" keystone

      su: Authentication failure

It gives error of authentication failure as there is no 'su' user in ubuntu. Then I tried command with sudo.

#sudo -s /bin/sh -c "keystone-manage db_sync" keystone

     No handlers could be found for logger "oslo_config.cfg"

It gives error like above. I am at beginning of installation so there is no nova or anything else. I have searched through forums most people facing same issue but no answer is there.

If I ignore error and go ahead to create endpoints it gives error like "error 500 when creating identity endpoint"

#openstack service create --name keystone --description "OpenStack Identity" identity

Internal Server Error (HTTP 500)

Followed all the steps, then I got stucked at Add the Identity Service - Install and configure section. Inside Install and configure components section I sent the following command:

 ln -s /etc/apache2/sites-available/wsgi-keystone.conf /etc/apache2/sites-enabled

But then the system says

No handlers could be found for logger "oslo_config.cfg"

What he's talking about ? I am at the beginning of the installation so till now there's no nova, nor anything else, just setting up keystone.

edit retag flag offensive close merge delete

5 answers

Sort by ยป oldest newest most voted

answered 2016-01-17 06:06:53 -0500

NuclearWorm gravatar image

Try removing (or commenting) option "verbose" in /etc/keystone/keystone.conf and restart keystone service.

edit flag offensive delete link more


Solved my issue. I hope it is not just hiding symptoms.

AJ NOURI gravatar imageAJ NOURI ( 2016-11-08 20:25:03 -0500 )edit

answered 2015-12-26 18:11:29 -0500

Eric Lajoie gravatar image

updated 2015-12-28 11:48:46 -0500

smaffulli gravatar image

Found fix:

  1. /etc/init.d/mysql stop
  2. (if it does not stop) ps -Al | grep mysql
  3. kill <mysql pid="">
  4. (Confirm its gone) ps -Al | grep mysql
  5. (Edit another mysql cnf file) vi /etc/mysql/mariadb.conf.d/mysqld.cnf
  6. Edit to bind IP here to be your correct public IP as used in the keystone.conf
  7. /etc/init.d/mysql start
  8. (confirm the mysql service is listening on public IP) netstat -lnp |grep mysql
  9. mysql -u keystone -p -h <public ip=""> -t keystone
  10. su -s /bin/sh -c "keystone-manage db_sync" keystone
edit flag offensive delete link more


NO, my friend no

Thomas Li gravatar imageThomas Li ( 2016-04-14 04:38:13 -0500 )edit

answered 2016-02-24 13:16:03 -0500

Please file this as a bug

edit flag offensive delete link more

answered 2016-02-26 06:25:54 -0500

Junieh gravatar image

Hi there!

Another reference for those who are following OpenStack tutorial for Ubuntu 14.04 LTS, is to make sure that the following line exists (otherwise it will try to use the SQLLite database that has concurrency problems):

[database] connection = mysql+pymysql://nova:nova@YOUR_HOST_IP/nova

In my case, the oslo log handler message keep being showed, but that do not influence in NOVA (the component that was throwing me the error during "su -s /bin/sh -c "nova-manage db sync" nova" command, and i was able to sucessfully continue with the implementation.

All the best

edit flag offensive delete link more

answered 2016-02-15 16:47:43 -0500

Check the bind ip.. for me was the wrong one here: sed -i 's/bind_ip = =' /etc/mongodb.conf

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools



Asked: 2015-12-21 00:43:23 -0500

Seen: 10,969 times

Last updated: Feb 26 '16