Devstack abort cause can't find mox 0.5.3

asked 2015-12-19 17:02:47 -0600

ilonka-o gravatar image

updated 2015-12-19 17:22:55 -0600

Hi guys! I try to install Devstack (Liberty) on a Ubuntu Server 14.04.03 in a Virtual Box. Actually I have the problem that stack.sh exit at the point "Collecting mox===0.5.3 (from -c /opt/stack/requirements/upper-constraints.txt (line 174))". Obviously there is no service or source stack.sh could find. I'm a newbie and haven't got any idea what I should do now :-(

Here is the related part of the log stack.sh.log:

2015-12-19 22:00:06.434 | Installing test-requirements for /opt/stack/tempest/test-requirements.txt
2015-12-19 22:00:06.434 | ++ sudo -H http_proxy= https_proxy= no_proxy= PIP_FIND_LINKS= /usr/local/bin/pip2.7 install -c /opt/stack/requirements/upper-constraints.txt -r /opt/stack/tempest/test-requirements.txt
2015-12-19 22:00:07.244 | Ignoring dnspython3: markers "python_version=='3.4'" don't match your environment
2015-12-19 22:00:07.383 | Requirement already satisfied (use --upgrade to upgrade): Sphinx===1.2.3 in /usr/local/lib/python2.7/dist-packages (from -c /opt/stack/requirements/upper-constraints.txt (line 24))
2015-12-19 22:00:07.385 | Requirement already satisfied (use --upgrade to upgrade): coverage===4.0.3 in /usr/local/lib/python2.7/dist-packages (from -c /opt/stack/requirements/upper-constraints.txt (line 90))
2015-12-19 22:00:07.385 | Requirement already satisfied (use --upgrade to upgrade): docutils===0.12 in /usr/local/lib/python2.7/dist-packages (from -c /opt/stack/requirements/upper-constraints.txt (line 113))
2015-12-19 22:00:07.386 | Requirement already satisfied (use --upgrade to upgrade): mock===1.3.0 in /usr/local/lib/python2.7/dist-packages (from -c /opt/stack/requirements/upper-constraints.txt (line 172))
2015-12-19 22:00:07.425 | Collecting mox===0.5.3 (from -c /opt/stack/requirements/upper-constraints.txt (line 174))
2015-12-19 22:00:12.441 |   Retrying (Retry(total=4, connect=None, read=None, redirect=None)) after connection broken by 'ProtocolError('Connection aborted.', gaierror(-2, 'Name or service not known'))': /simple/mox/
2015-12-19 22:00:17.948 |   Retrying (Retry(total=3, connect=None, read=None, redirect=None)) after connection broken by 'ProtocolError('Connection aborted.', gaierror(-2, 'Name or service not known'))': /simple/mox/
2015-12-19 22:00:23.957 |   Retrying (Retry(total=2, connect=None, read=None, redirect=None)) after connection broken by 'ProtocolError('Connection aborted.', gaierror(-2, 'Name or service not known'))': /simple/mox/
2015-12-19 22:00:30.966 |   Retrying (Retry(total=1, connect=None, read=None, redirect=None)) after connection broken by 'ProtocolError('Connection aborted.', gaierror(-2, 'Name or service not known'))': /simple/mox/
2015-12-19 22:00:39.975 |   Retrying (Retry(total=0, connect=None, read=None, redirect=None)) after connection broken by 'ProtocolError('Connection aborted.', gaierror(-2, 'Name or service not known'))': /simple/mox/
2015-12-19 22:00:49.985 |   Retrying (Retry(total=4, connect=None, read=None, redirect=None)) after connection broken by 'ProtocolError('Connection aborted.', gaierror(-2, 'Name or service not known'))': /simple/mox/
2015-12-19 22:01:00.491 |   Retrying (Retry(total=3, connect=None, read=None, redirect=None)) after connection broken by 'ProtocolError('Connection aborted.', gaierror(-2, 'Name or service not ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-12-19 17:36:11 -0600

aimonb gravatar image

Try installing mox manually: apt-get install python-mox If it offers the incorrect version you can download it and install from here: http://launchpadlibrarian.net/167352978/python-mox_0.5.3-3build1_all.deb (http://launchpadlibrarian.net/1673529...)

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-12-19 17:02:47 -0600

Seen: 721 times

Last updated: Dec 19 '15