Designate: neutron_floatingip not triggered

asked 2015-12-18 04:50:43 -0500

Herr-Herner gravatar image

I have enabled the Neutron Floating IP Handler in designate, but the handler does not get triggered. The message from Neutron gets transmitted via RabbitMQ:

Node:         rabbit@os-controller01
Connection:   10.152.132.202:49818 -> 10.152.132.201:5672
Virtual host: openstack
User:         neutron
Channel:      1
Exchange:     neutron
Routing keys: [<<"notifications.info">>]
Routed queues: [<<"notifications.info">>]
Properties:   [{<<"priority">>,signedint,0},
               {<<"delivery_mode">>,signedint,2},
               {<<"headers">>,table,[]},
               {<<"content_encoding">>,longstr,<<"utf-8">>},
               {<<"content_type">>,longstr,<<"application/json">>}]
Payload: 
{"oslo.message": "{\"_context_domain\": null, \"_context_roles\": [\"admin\"], \"event_type\": \"floatingip.update.end\", \"_context_request_id\": \"req-762f38c2-5d32-44b8-b7f2-004b53074af0\", \"timestamp\": \"2015-12-18 10:19:35.299940\", \"_context_tenant_id\": \"7fdd23889b214e66b94f498c9529fbd6\", \"_context_user\": \"9143aa3056e543a48bf358adfa025a4e\", \"_unique_id\": \"e15b4248ca2c494781e86bf764649b46\", \"_context_resource_uuid\": null, \"_context_tenant_name\": \"demo\", \"_context_user_id\": \"9143aa3056e543a48bf358adfa025a4e\", \"payload\": {\"floatingip\": {\"floating_network_id\": \"d8bacc37-d60a-4ff6-ade2-7eeec73bf248\", \"router_id\": \"3948fdeb-eab2-437a-8193-f35a352c49bc\", \"fixed_ip_address\": \"192.168.1.8\", \"floating_ip_address\": \"10.30.216.130\", \"tenant_id\": \"7fdd23889b214e66b94f498c9529fbd6\", \"status\": \"DOWN\", \"port_id\": \"987c3e33-c357-4c9e-aa4a-5a267d97fdfa\", \"id\": \"ae8b043d-79c7-4024-bc73-002a9df25d98\"}}, \"_context_project_name\": \"demo\", \"_context_user_identity\": \"9143aa3056e543a48bf358adfa025a4e 7fdd23889b214e66b94f498c9529fbd6 - - -\", \"_context_auth_token\": \"713e6fcd785545cab884c5d670dca0a0\", \"_context_show_deleted\": false, \"_context_tenant\": \"7fdd23889b214e66b94f498c9529fbd6\", \"priority\": \"INFO\", \"_context_read_only\": false, \"_context_is_admin\": true, \"_context_project_id\": \"7fdd23889b214e66b94f498c9529fbd6\", \"_context_project_domain\": null, \"_context_timestamp\": \"2015-12-18 10:19:34.919480\", \"_context_user_domain\": null, \"_context_user_name\": \"admin\", \"publisher_id\": \"network.os-network02\", \"message_id\": \"df8faddc-c9e0-473d-9528-f1c576d1e22e\"}", "oslo.version": "2.0"}

This my designate.conf:

[DEFAULT]
# Where an option is commented out, but filled in this shows the default
# value of that option

########################
## General Configuration
########################
# Show more verbose log output (sets INFO log level output)
verbose = True

# Show debugging output in logs (sets DEBUG log level output)
debug = True

# Top-level directory for maintaining designate's state
state_path = /var/lib/designate

# Log Configuration
#log_config = None

# Log directory
log_dir = /var/log/designate

# Driver used for issuing notifications
notification_driver = messagingv2

# Notification Topics
notification_topics = notifications

# Use "sudo designate-rootwrap /etc/designate/rootwrap.conf" to use the real
# root filter facility.
# Change to "sudo" to skip the filtering and just run the comand directly
root_helper = sudo designate-rootwrap /etc/designate/rootwrap.conf

# Which networking API to use, Defaults to neutron
network_api = neutron

# The messaging driver to use, defaults to rabbit. Other
# drivers include qpid and zmq. (string value)
rpc_backend = rabbit

host = os-dns01

#-----------------------
# RabbitMQ Config
#-----------------------
[oslo_messaging_rabbit]
rabbit_userid = designate
rabbit_password = designatepass
rabbit_virtual_host = openstack
rabbit_use_ssl = False
rabbit_hosts = os-rabbit01:5672,os-rabbit02:5672
rabbit_ha_queues = True

########################
## Service Configuration
########################
#-----------------------
# Central Service
#-----------------------
[service:central]
# Number of central worker processes to spawn
workers = 2

# Number of central greenthreads to spawn
#threads = 1000

# Maximum domain name length
max_domain_name_len = 255

# Maximum recordset name length
max_recordset_name_len = 255

# Minimum TTL
#min_ttl = None

# The name of the default pool
default_pool_id = '794ccc2c-d751-44fe-b57f-8894c9f5c842'

## Managed resources settings

# Email to use for managed resources like domains created by the FloatingIP API
#managed_resource_email = hostmaster@example.com.

# Tenant ID to own all managed resources - like auto-created records etc.
#managed_resource_tenant_id = 123456

backend_driver = bind9

#-----------------------
# API Service
#-----------------------
[service:api]
# Number of api worker processes to spawn
workers = 2

# Number of api greenthreads to spawn
#threads = 1000

# Enable host request headers
#enable_host_header = False

# The base uri used in responses
api_base_uri = http://$api_host:$api_port

# Address to bind the API server
api_host = 10.152.132.201

# Port the bind the API server to
api_port = 9001

# Maximum line size of message headers to be accepted. max_header_line may
# need to be increased when using large tokens (typically those generated by
# the Keystone v3 API with big service catalogs).
#max_header_line ...
(more)
edit retag flag offensive close merge delete