Ask Your Question
0

packstack --allinone issues

asked 2015-12-17 04:07:27 -0500

yummy-bian gravatar image

updated 2015-12-17 04:26:32 -0500

I'm trying to deploy rdo on a CentOS7 server. I'm following the directions from the http://openstack.redhat.com/Quickstart (Quickstart) page.Everything looks fine but when i try to run packstack --allinone command i got these prompt.

ERROR:root:Failed to load plugin from file prescript_000.py
ERROR:root:Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 884, in loadPlugins
    moduleobj = __import__(moduleToLoad)
  File "/usr/lib/python2.7/site-packages/packstack/plugins/prescript_000.py", line 35, in <module>
    from packstack.modules.documentation import update_params_usage
  File "/usr/lib/python2.7/site-packages/packstack/modules/documentation.py", line 20, in <module>
    from docutils import core
  File "/usr/lib/python2.7/site-packages/docutils/core.py", line 20, in <module>
    from docutils import frontend, io, utils, readers, writers
  File "/usr/lib/python2.7/site-packages/docutils/frontend.py", line 41, in <module>
    import docutils.utils
  File "/usr/lib/python2.7/site-packages/docutils/utils/__init__.py", line 20, in <module>
    import docutils.io
  File "/usr/lib/python2.7/site-packages/docutils/io.py", line 18, in <module>
    from docutils.utils.error_reporting import locale_encoding, ErrorString, ErrorOutput
  File "/usr/lib/python2.7/site-packages/docutils/utils/error_reporting.py", line 46, in <module>
    locale_encoding = locale.getlocale()[1] or locale.getdefaultlocale()[1]
  File "/usr/lib64/python2.7/locale.py", line 511, in getdefaultlocale
    return _parse_localename(localename)
  File "/usr/lib64/python2.7/locale.py", line 443, in _parse_localename
    raise ValueError, 'unknown locale: %s' % localename
ValueError: unknown locale: UTF-8

ERROR:root:Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 949, in main
    loadPlugins()
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 892, in loadPlugins
    raise Exception("Failed to load plugin from file %s" % item)
Exception: Failed to load plugin from file prescript_000.py


ERROR : Failed to load plugin from file prescript_000.py
Traceback (most recent call last):
  File "/usr/bin/packstack", line 15, in <module>
    run_setup.main()
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 1019, in main
    print(output_messages.ERR_CHECK_LOG_FILE_FOR_MORE_INFO % (logFile))
UnboundLocalError: local variable 'logFile' referenced before assignment

Anyone know what happened? TKS.

edit retag flag offensive close merge delete

Comments

Resolved.Just add some lines to the ~/.bash_profile

export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8
yummy-bian gravatar imageyummy-bian ( 2015-12-18 05:20:19 -0500 )edit

I never thought bash needs these things to be exported... Well new thing to learn from this. Thanks

Prateek K gravatar imagePrateek K ( 2015-12-18 05:24:04 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
0

answered 2015-12-17 04:14:47 -0500

Prateek K gravatar image

Oops this is a problem in the packstack itself ... Are you sure you are using the stable packstack version ?

edit flag offensive delete link more

Comments

I just install it using yum install -y openstack-packstack. It seems openstack-packstack-7.0.0-0.7.dev1661.gaf13b7e.el7.noarch.

yummy-bian gravatar imageyummy-bian ( 2015-12-17 04:39:08 -0500 )edit
0

answered 2015-12-17 05:44:38 -0500

yummy-bian gravatar image

updated 2015-12-18 05:19:11 -0500

I can't still resolve it after rollback to kilo.

edit flag offensive delete link more

Comments

What repo did you installed on Centos7 ?

Prateek K gravatar imagePrateek K ( 2015-12-17 06:02:34 -0500 )edit

I mean i have resolved the packstack to kilo version.

yummy-bian gravatar imageyummy-bian ( 2015-12-17 20:39:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-12-17 04:07:27 -0500

Seen: 2,539 times

Last updated: Dec 18 '15