Ask Your Question
2

[Liberty] keystone service entity creation (HTTP 500)

asked 2015-12-16 17:10:27 -0500

dannch gravatar image

updated 2015-12-17 02:34:18 -0500

Hi, I'm following the installation guide to deploy in a centos environment (link:http://docs.openstack.org/liberty/install-guide-rdo/keystone-services.html ).

I added the the variables

export OS_IDENTITY_API_VERSION="3"
export OS_TOKEN="2aea3e1a346d56c3bcbb"
export OS_URL="http://liberty21.upcloud.com:35357/v3"

and then run the command:

openstack service create \
  --name keystone --description "OpenStack Identity" identity

with the following result message:

"An unexpected error prevented the server from fulfilling your request. (HTTP 500) (Request-ID: req-6b58d146-ac1f-40e3-8e05-ae35e81425bb)"

The Request-ID changes every time I try the command. I checked the token in the /etc/keystone/keystone.conf that is the same in the variable OS_TOKEN. Also, I removed the # in the keystone.conf file (Another person had that problem in a similar question).

In another post someone suggested to run the command in --debug. Here is my output:

[root@liberty21 ~]# openstack --debug service create --name keystone --description "OpenStack Identity" identity --enable
START with options: ['--debug', 'service', 'create', '--name', 'keystone', '--description', 'OpenStack Identity', 'identity', '--enable']
options: Namespace(access_token_endpoint='', auth_type='', auth_url='', cacert='', client_id='', client_secret='', cloud='', debug=True, default_domain='default', deferred_help=False, domain_id='', domain_name='', endpoint='', identity_provider='', insecure=None, interface='', log_file=None, os_compute_api_version='', os_identity_api_version='3', os_image_api_version='', os_network_api_version='', os_object_api_version='', os_project_id=None, os_project_name=None, os_volume_api_version='', password='', project_domain_id='', project_domain_name='', project_id='', project_name='', protocol='', region_name='', scope='', timing=False, token='2aea3e1a346d56c3bcbb', trust_id='', url='http://liberty21.upcloud.com:35357/v3', user_domain_id='', user_domain_name='', user_id='', username='', verbose_level=3, verify=None)
defaults: {'auth_type': 'token_endpoint', 'compute_api_version': '2', 'key': None, 'database_api_version': '1.0', 'api_timeout': None, 'baremetal_api_version': '1', 'cacert': None, 'image_api_use_tasks': False, 'floating_ip_source': 'neutron', 'orchestration_api_version': '1', 'interface': None, 'network_api_version': '2', 'image_format': 'qcow2', 'object_api_version': '1', 'image_api_version': '2', 'verify': True, 'identity_api_version': '2', 'volume_api_version': '1', 'cert': None, 'secgroup_source': 'neutron', 'dns_api_version': '2', 'disable_vendor_agent': {}}
cloud cfg: {'auth_type': 'token_endpoint', 'compute_api_version': '2', 'orchestration_api_version': '1', 'database_api_version': '1.0', 'interface': None, 'network_api_version': '2', 'image_format': 'qcow2', 'object_api_version': '1', 'image_api_version': '2', 'verify': True, 'timing': False, 'dns_api_version': '2', 'verbose_level': 3, 'region_name': '', 'api_timeout': None, 'baremetal_api_version': '1', 'auth': {'url': 'http://liberty21.upcloud.com:35357/v3', 'token': '2aea3e1a346d56c3bcbb'}, 'default_domain': 'default', 'image_api_use_tasks': False, 'floating_ip_source': 'neutron', 'key': None, 'cacert': None, 'deferred_help': False, 'identity_api_version': '3', 'volume_api_version': '1', 'cert': None, 'secgroup_source': 'neutron', 'debug': True, 'disable_vendor_agent': {}}
compute API version 2, cmd group openstack.compute.v2
network API version 2, cmd group openstack.network.v2
image API version 2, cmd group openstack.image.v2
volume API version 1, cmd group openstack.volume.v1
identity API version 3, cmd group openstack.identity.v3
object_store API version 1, cmd group openstack.object_store.v1
command: service create -> openstackclient.identity.v3.service.CreateService
Auth plugin token_endpoint selected
auth_type: token_endpoint
Using auth plugin: token_endpoint
Using parameters {'url': 'http://liberty21.upcloud.com:35357/v3', 'token': '2aea3e1a346d56c3bcbb'}
Get auth_ref
take_action(Namespace(columns=[], description='OpenStack Identity', disable=False, enable=True, formatter='table', max_width=0, name='keystone', noindent=False, prefix='', type='identity', variables=[]))
Instantiating identity client: <class 'keystoneclient.v3.client.Client'>
REQ: curl -g -i -X POST http://liberty21.upcloud.com:35357/v3/services -H "User-Agent: python-keystoneclient" -H "Content-Type: application/json" -H "Accept: application/json" -H "X-Auth-Token: {SHA1}51967b8a4b69e9a06afa9e85dcb45ebe1d43e157" -d '{"service": {"enabled": true, "type": "identity", "description": "OpenStack Identity", "name": "keystone"}}'
Starting new HTTP connection (1): liberty21.upcloud.com
"POST /v3/services ...
(more)
edit retag flag offensive close merge delete

Comments

Have a look at the keystone log file under /var/log/keystone. First focus on lines labeled with "error". You may also benefit from switching on debugging in the config file.

Also, when posting ouput, format it using the "101010" button.

Bernd Bausch gravatar imageBernd Bausch ( 2015-12-17 01:40:28 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-12-17 01:54:39 -0500

Sahana gravatar image

I have encountered the same issue on Juno. To troubleshoot this issue, added a line to /etc/keystone/keystone.conf as below and that worked for me.!

vi /etc/keystone/keystone.conf

connection = mysql://keystone:pass@aioX/keystone

connection = mysql://keystone:pass@localhost/keystone # new line added to suppress HTTP 500 error

After that run these commands again to reflect keystone.conf changes made,

Populate the database tables for the Identity Service:

su -s /bin/sh -c "keystone-manage db_sync" keystone

Restart the Identity Service: sudo systemctl enable openstack-keystone.service sudo systemctl start openstack-keystone.service

export OS_SERVICE_TOKEN=ADMIN_TOKEN

export OS_SERVICE_ENDPOINT=http://aioX:35357/v2.0

Thanks!

edit flag offensive delete link more

Comments

1

Thanks a lot. On a quick note, the lines are under [database], in case someone need to find it quickly, they can use /\<database\>

dannch gravatar imagedannch ( 2015-12-17 11:40:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-12-16 17:09:08 -0500

Seen: 1,573 times

Last updated: Dec 17 '15