nova-api did not start

asked 2015-12-14 07:39:05 -0600

Pradip gravatar image

Hello,

We are trying to setup a devstack env, getting the following error, tried with clean, unstack, stacking:

2015-12-14 13:33:16.127 | + screen -S stack -p n-api -X stuff '/usr/local/bin/nova-api & echo $! >/opt/stack/status/stack/n-api.pid; fg || echo "n-api failed to start" |  'ee "/opt/stack/status/stack/n-api.failure"
2015-12-14 13:33:16.133 | + echo 'Waiting for nova-api to start...'
2015-12-14 13:33:16.134 | Waiting for nova-api to start...
2015-12-14 13:33:16.134 | + wait_for_service 60 http://192.168.10.13:8774
2015-12-14 13:33:16.135 | + local timeout=60
2015-12-14 13:33:16.135 | + local url=http://192.168.10.13:8774
2015-12-14 13:33:16.135 | + timeout 60 sh -c 'while ! curl -g -k --noproxy '\''*'\'' -s http://192.168.10.13:8774 >/dev/null; do sleep 1; done'

2015-12-14 13:34:16.147 | + die 799 'nova-api did not start'
2015-12-14 13:34:16.148 | + local exitcode=0
2015-12-14 13:34:16.148 | [Call Trace]
2015-12-14 13:34:16.149 | ./stack.sh:1214:start_nova_api
2015-12-14 13:34:16.149 | /home/stack/devstack/lib/nova:799:die
2015-12-14 13:34:16.155 | [ERROR] /home/stack/devstack/lib/nova:799 nova-api did not start
2015-12-14 13:34:17.162 | Error on exit
2015-12-14 13:34:17.263 | Another app is currently holding the xtables lock. Perhaps you want to use the -w option?
stack@openstack3:~/devstack$
stack@openstack3:~/devstack$ 2015-12-14 13:34:17.552 | /bin/sh: 1: kill: Usage: kill [-s sigspec | -signum | -sigspec] [pid | job]... or
2015-12-14 13:34:17.555 | kill -l [exitstatus]

Here is what is in the nova.log:

2015-12-14 08:33:18.176 DEBUG oslo_concurrency.lockutils [-] Acquired semaphore "singleton_lock" from (pid=18352) lock /usr/local/lib/python2.7/dist-packages/oslo_concurrency/lockutils.py:198
2015-12-14 08:33:18.176 DEBUG oslo_concurrency.lockutils [-] Releasing semaphore "singleton_lock" from (pid=18352) lock /usr/local/lib/python2.7/dist-packages/oslo_concurrency/lockutils.py:211
2015-12-14 08:33:18.177 DEBUG nova.wsgi [-] Loading app ec2 from /etc/nova/api-paste.ini from (pid=18352) load_app /opt/stack/nova/nova/wsgi.py:543
2015-12-14 08:33:18.521 INFO oslo_service.periodic_task [-] Skipping periodic task _periodic_update_dns because its interval is negative
2015-12-14 08:33:18.522 WARNING nova.api.ec2.cloud [-] Deprecated: The in tree EC2 API is deprecated as of Kilo release and may be removed in a future release. The openstack ec2-api project http://git.openstack.org/cgit/openstack/ec2-api/ is the target replacement for this functionality.
2015-12-14 08:33:18.722 ERROR nova.wsgi [-] Could not bind to 0.0.0.0:8773
2015-12-14 08:33:18.723 CRITICAL nova [-] error: [Errno 98] Address already in use

2015-12-14 08:33:18.723 TRACE nova Traceback (most recent call last):
2015-12-14 08:33:18.723 TRACE nova   File "/usr/local/bin/nova-api", line 10, in <module>
2015-12-14 08:33:18.723 TRACE nova     sys.exit(main())
2015-12-14 08:33:18.723 TRACE nova   File "/opt/stack/nova/nova/cmd/api.py", line 49, in main
2015-12-14 08 ...
(more)
edit retag flag offensive close merge delete

Comments

1

Looks like environment was not cleaned before doing the stack. Clean it first and check for any ports in use like 8773. If its there, kill all the process running and run the stack again.

Bipin gravatar imageBipin ( 2015-12-14 21:49:46 -0600 )edit

Thanks. It worked.

Pradip gravatar imagePradip ( 2015-12-15 08:29:25 -0600 )edit