Ask Your Question
0

nova unable to establish connection

asked 2015-12-13 07:38:43 -0600

matansab gravatar image

updated 2015-12-14 00:57:57 -0600

Hi, I am running devstack on Ubuntu, when i am trying to run anything which is related to Nova such as :

nova list, nova service-list etc.

I am getting

ERROR (ConnectFailure): Unable to  establish connection to  http://MY.IP.ADDRESS:8774/v2.1/533aa7ac0e544e83956fa55e2a0fa542

Can someone please assist with that?

---edit ----

matan@matan-virtual-machine:~$ sudo netstat -ntlp | grep 8774 returns nothing

The output of keystone endpoint-list is:

+----------------------------------+-----------+-----------------------------------------------+-----------------------------------------------+-----------------------------------------------+----------------------------------+ | id |
region | publicurl | internalurl
| adminurl
| service_id | +----------------------------------+-----------+-----------------------------------------------+-----------------------------------------------+-----------------------------------------------+----------------------------------+ | 2a249b30000c4c2c8f8bdf46c834d59f | RegionOne | http://10.136.242.210:8776/v2/$(tenan... | http://10.136.242.210:8776/v2/$(tenan... | http://10.136.242.210:8776/v2/$(tenan... | 617df1ea592e46d1ba418705ec2dccc6 | | 5b3d9d0180624e72a15126c3c37e777f | RegionOne |
http://10.136.242.210:9292 | http://10.136.242.210:9292 | http://10.136.242.210:9292 | 0a0b0bc37d2f4afdbc162b8d54dc7888 | | a6c50f7bc2de431e861c56d77c13e5a8 | RegionOne | http://10.136.242.210:8774/v2.1/$(ten... | http://10.136.242.210:8774/v2.1/$(ten... | http://10.136.242.210:8774/v2.1/$(ten... | 27683f647a26495688d3d299e07a0154 | | b630b0771107471a9a9f435d6031bd21 | RegionOne |
http://10.136.242.210:5000/v2.0
|
http://10.136.242.210:5000/v2.0
|
http://10.136.242.210:35357/v2.0
| 3605cff35ed04da48751b13236dab88d | | c30c10739c6a43c6a7963995bf976dd7 | RegionOne | http://10.136.242.210:8774/v2/$(tenan... | http://10.136.242.210:8774/v2/$(tenan... | http://10.136.242.210:8774/v2/$(tenan... | 8835d7be78904c819a54cfc1e208d4a5 | | c6dd5439e4f8443e92fe547196b83589 | RegionOne |
http://10.136.242.210:8773/ | http://10.136.242.210:8773/ | http://10.136.242.210:8773/ | 03b4122da6e6456fbe8de58389ec7f61 | | db4fed88689f4ac8a3cb6434f8ff0f6f | RegionOne | http://10.136.242.210:8776/v1/$(tenan... | http://10.136.242.210:8776/v1/$(tenan... | http://10.136.242.210:8776/v1/$(tenan... | b96cdebc69b6433faba227ec4b4533e3 | +----------------------------------+-----------+-----------------------------------------------+-----------------------------------------------+-----------------------------------------------+----------------------------------+

edit retag flag offensive close merge delete

Comments

Kindly give the output of netstat -ntlp | grep 8774 and keystone endpoint-list

Bipin gravatar imageBipin ( 2015-12-13 22:11:09 -0600 )edit

Hi Bipin, I added the relevant outputs.

matansab gravatar imagematansab ( 2015-12-14 00:58:20 -0600 )edit

Hi, your compute service (nova) is not running. Please restart it and try again. It will work.

Bipin gravatar imageBipin ( 2015-12-14 01:00:49 -0600 )edit

I can't understand how to restart nova specifically on devstack

matansab gravatar imagematansab ( 2015-12-14 01:26:50 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-12-14 02:19:45 -0600

Bipin gravatar image

Hello

1. cd to devstack home
2. run ./rejoin-stack
3. find the nova-api service by press crl+a +" then select the nova-api eg: n-api then press enter key
4. kill the nova-service by crl+ c then press up arrow key to find the command to start the nova api and press enter, you will see the nova-api service restarted.

Regards

edit flag offensive delete link more
0

answered 2015-12-14 01:13:11 -0600

best way to check if the services are running or not . Please install openstack-utils package in the server.

It will install the command openstack-status which will tell you what all the services are running or not.

In this case, nova-api might not be running. Did you check the logs in /var/log/nova ?

edit flag offensive delete link more

Comments

It is devstack, it doesn't have a /var/log/nova file..

matansab gravatar imagematansab ( 2015-12-14 01:16:57 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-12-13 07:38:43 -0600

Seen: 6,250 times

Last updated: Dec 14 '15