Ask Your Question
4

devstack installation : worlddump erro

asked 2015-12-11 11:46:48 -0500

abdelhamid gravatar image

Hi, can someone plz help me, i'm trying to install openstack liberty using the devstack script but i get the following error :

> 2015-12-11 17:37:06.240 |   File
> "/usr/local/lib/python2.7/dist-packages/tox/config.py",
> line 904, in _getdict
>     2015-12-11 17:37:06.240 |     name, rest = line.split('=', 1)
>     2015-12-11 17:37:06.240 | **ValueError: need more than 1 value to unpack**
>     2015-12-11 17:37:06.252 | + exit_trap
>     2015-12-11 17:37:06.252 | + local r=1
>     2015-12-11 17:37:06.253 | ++ jobs -p
>     2015-12-11 17:37:06.254 | + jobs=
>     2015-12-11 17:37:06.254 | + [[ -n '' ]]
>     2015-12-11 17:37:06.254 | + kill_spinner
>     2015-12-11 17:37:06.254 | + '[' '!' -z '' ']'
>     2015-12-11 17:37:06.254 | + [[ 1 -ne 0 ]]
>     2015-12-11 17:37:06.255 | + echo 'Error on exit'
>     2015-12-11 17:37:06.255 | Error on exit
>     2015-12-11 17:37:06.255 | + [[ -z /opt/stack/logs ]]
>     2015-12-11 17:37:06.255 | + /home/controller/devstack/tools/worlddump.py
> -d /opt/stack/logs
>     2015-12-11 17:37:06.673 | + exit 1
edit retag flag offensive close merge delete

Comments

I'm having the same issue on Fedora Server 23, also tried version 22;

2015-12-12 15:25:29.014 | ++ pushd /opt/stack/tempest
2015-12-12 15:25:29.059 | /opt/stack/tempest ~/devstack
2015-12-12 15:25:29.060 | ++ tox --notest -efull
2015-12-12 15:25:29.217 | ValueError: need more than 1 value to unpack
run Jon run gravatar imagerun Jon run ( 2015-12-12 09:46:01 -0500 )edit

i have the exact same error any luck figuring it out?

Ardenexal gravatar imageArdenexal ( 2015-12-13 03:26:46 -0500 )edit

6 answers

Sort by ยป oldest newest most voted
0

answered 2015-12-11 13:00:00 -0500

Seems to be related to a new version of tox:

https://review.openstack.org/#/c/256620

There's a one-line fix you can use from that patchset that got me past the error

edit flag offensive delete link more
0

answered 2015-12-11 12:36:07 -0500

rhsu gravatar image

Please see https://bugs.launchpad.net/devstack/+bug/1525352 (https://bugs.launchpad.net/devstack/+...), there is a fix awaiting review. Workaround is to revert to Tox 2.2.1.

edit flag offensive delete link more
0

answered 2015-12-12 10:19:27 -0500

run Jon run gravatar image

Sorted, read in another post tox-2.3.0 is not compatible (thanks ZhiQiang Fan) so we need to downgrade;

sudo pip uninstall tox
sudo pip install tox==2.1.1

Then run stack.sh again

edit flag offensive delete link more

Comments

thank you this worked for me

habesha gravatar imagehabesha ( 2015-12-14 09:34:34 -0500 )edit
0

answered 2015-12-12 06:20:18 -0500

habesha gravatar image

I'm getting the same error, any help please

edit flag offensive delete link more
0

answered 2015-12-13 04:54:34 -0500

chucky gravatar image

I am having the same issue installing on the most recent and updated centos. Can you please assist?

edit flag offensive delete link more
0

answered 2015-12-12 07:39:13 -0500

You need to cap the tox installation i.e. open file ~/devstack/lib/tempest and replace 'pip_install tox' with 'pip_install 'tox<2.3.0'' and run stack.sh again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

4 followers

Stats

Asked: 2015-12-11 11:46:48 -0500

Seen: 992 times

Last updated: Dec 12 '15