Ask Your Question
0

internet stops working in Host after starting running devstack(stack.sh) [closed]

asked 2015-12-10 11:20:11 -0500

saurabh19 gravatar image

updated 2015-12-13 11:10:46 -0500

Again starts to work after ./unstack.sh or restarting pc
This is All in one machine openstack deployment using devstack

[[local|localrc]]
HOST_IP=192.168.1.4
SERVICE_HOST=192.168.1.4
MYSQL_HOST=192.168.1.4
RABBIT_HOST=192.168.1.4
GLANCE_HOSTPORT=192.168.1.4:9292

FIXED_RANGE=10.0.1.0/24
FLOATING_RANGE=192.168.1.0/24
PUBLIC_NETWORK_GATEWAY=192.168.1.1  
Q_FLOATING_ALLOCATION_POOL=start=192.168.1.225,end=192.168.1.250
NETWORK_GATEWAY=10.0.1.1

disable_service n-net
# Enable Neutron
ENABLED_SERVICES+=,q-svc,q-dhcp,q-meta,q-agt,q-l3,neutron


## Neutron options
Q_USE_SECGROUP=True
Q_L3_ENABLED=True
PUBLIC_INTERFACE=eth0
Q_USE_PROVIDERNET_FOR_PUBLIC=True
OVS_PHYSICAL_BRIDGE=br-ex
PUBLIC_BRIDGE=br-ex
OVS_BRIDGE_MAPPINGS=public:br-ex
--------------------------------------------------------------------------------

sudo ovs-vsctl show
7bdebfac-b26a-4719-8236-fb8727e9dd38
    Bridge br-tun
        fail_mode: secure
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-ex
        Port br-ex
            Interface br-ex
                type: internal
        Port phy-br-ex
            Interface phy-br-ex
                type: patch
                options: {peer=int-br-ex}
    Bridge br-int
        fail_mode: secure
        Port "qr-61d8d4a6-3f"
            tag: 1
            Interface "qr-61d8d4a6-3f"
                type: internal
        Port "qg-a5d37e78-8b"
            tag: 2
            Interface "qg-a5d37e78-8b"
                type: internal
        Port int-br-ex
            Interface int-br-ex
                type: patch
                options: {peer=phy-br-ex}
        Port br-int
            Interface br-int
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
    ovs_version: "2.0.2"
edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by saurabh19
close date 2015-12-15 11:10:39.141477

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-12-10 23:07:37 -0500

Prateek K gravatar image

its the OVS that is the culript here ... I have ran into similar issue. In my case what was happening is my main interface i.e. which was used for internet and ssh was added as a port to the OVS-bridge and then the ip which was on the interface was on the bridge ...

So now if I tried to access net or anything it would not work. Man ping also stopped working :).... But after going deeper I found that the dhcp server who was giving the IP on the interface also noted the MAC address of the machine which suddenly got changed ...The router considered it as a threat or something and bam the IP got blacklisted :P....A single IP with mutiple MAC address it did not liked... ooopppsss....

Solution was simple I noted the MAC address of my interface and set the mac address of OVS bridge via command. Yes its simple but took me a lot of time to figure it out. Hope it works in your case too

edit flag offensive delete link more

Comments

Yes, this totally seems to be happening in my case, coz I have recently changed my broadband provider and the router. It will be really helpful if u could give me some more information about the solution, or any link please. thanks

saurabh19 gravatar imagesaurabh19 ( 2015-12-11 02:05:16 -0500 )edit

ok ... So I am assuming your interface name to be eth0(Change to the name which you have on your machine).

  1. ovs-vsctl set bridge <bridge_name> other-config:hwaddr=<mac address="" of="" the="" interface="" which="" is="" added="" as="" a="" port="" in="" the="" bridge="">

  2. ovs-vsctl show will give you info about the bridge and port

Prateek K gravatar imagePrateek K ( 2015-12-11 02:13:00 -0500 )edit

ovs-vsctl set bridge br-ex other-config:hwaddr=50:b7:c3:06:7d:06
I used this but no success. this is mac address of eth0 as per ifconfig Please guide me what I did wrong

saurabh19 gravatar imagesaurabh19 ( 2015-12-11 10:29:37 -0500 )edit

does ovs-vsctl show gives that eth0 is added as a port in br-ex and br-ex must have ip and eth0 should not have. Plus do a route -s and see weather br-ex has a route. If still facing issues post the output of the commands of ovs and route and we will see

Prateek K gravatar imagePrateek K ( 2015-12-12 04:02:17 -0500 )edit

also output of ifconfig etho and ifconfig br-ex

Prateek K gravatar imagePrateek K ( 2015-12-12 04:02:44 -0500 )edit
0

answered 2015-12-13 11:17:23 -0500

saurabh19 gravatar image

my ifconfig output br-ex Link encap:Ethernet HWaddr 22:4e:db:a1:d1:42
inet addr:192.168.1.1 Bcast:0.0.0.0 Mask:255.255.255.0 UP BROADCAST RUNNING MTU:1500 Metric:1 RX packets:568 errors:0 dropped:0 overruns:0 frame:0 TX packets:399 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:67950 (67.9 KB) TX bytes:79967 (79.9 KB)

br-int Link encap:Ethernet HWaddr ce:fd:31:cc:08:4b
inet6 addr: fe80::8a6:89ff:fe05:90a/64 Scope:Link UP BROADCAST RUNNING MTU:1500 Metric:1 RX packets:700 errors:0 dropped:0 overruns:0 frame:0 TX packets:8 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:152150 (152.1 KB) TX bytes:648 (648.0 B)

br-tun Link encap:Ethernet HWaddr da:e5:c0:31:f8:49
inet6 addr: fe80::b0ca:1cff:fef9:92a2/64 Scope:Link UP BROADCAST RUNNING MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:8 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:0 (0.0 B) TX bytes:648 (648.0 B)

eth0 Link encap:Ethernet HWaddr 50:b7:c3:06:7d:06
inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0 inet6 addr: fe80::52b7:c3ff:fe06:7d06/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:14262 errors:0 dropped:0 overruns:0 frame:0 TX packets:16251 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:11309204 (11.3 MB) TX bytes:2439097 (2.4 MB)

PS br-ex is getting an ip that is my gateway ip, Is it wrong? In ovs-vsctl I dont have any port for eth0

edit flag offensive delete link more

Comments

It is actually wrong... What you need to do is add eth0 as a port to br-ex( Command- ovs-vsctl add-port br-ex eth0). 2. Set eth0 to have 0.0.0.0( ifconfig eth0 0.0.0.0 up). Then finally set br-ex ip to eth0's IP which is 192.168.1.4.. if eth0's get IP via dhcp then create br-ex interface file

Prateek K gravatar imagePrateek K ( 2015-12-13 23:12:21 -0500 )edit

Thanks, you are right. I did what u said still facing some issues probably because of routing table. Working on it. I'll update soon the results

saurabh19 gravatar imagesaurabh19 ( 2015-12-14 22:30:14 -0500 )edit

Thanks @Prateek.I Fixed the issue. couldn't have done this without you. You were really helpful

saurabh19 gravatar imagesaurabh19 ( 2015-12-15 11:09:53 -0500 )edit

No problem ... I am happy the issue got resolved :)

Prateek K gravatar imagePrateek K ( 2015-12-15 22:55:38 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-12-10 11:20:11 -0500

Seen: 377 times

Last updated: Dec 13 '15