Ask Your Question
0

lbaas 404 not found

asked 2015-12-10 08:55:27 -0500

venturozzaccio gravatar image

updated 2015-12-11 05:57:38 -0500

I am trying to use lbaas on standard 2-nodes ubuntu deployment of Liberty, I tried changing plugin and driver in neutron-lbaas.conf and lbaas_agent.ini but i keep receiving this error when i use

neutron lbaas-loadbalancer-create --name lb1 8c159e5f-9ef1-4c7b-b380-127be5bfbb31

and I couldn't find the appropiate log file

404 Not Found

The resource could not be found.

--- Following indications ---

neutron-lbaas-agent is installed but is not alive under neutron agent-list, it keeps respawning and giving me the following errors:

If i set lbaasv2 in serive_plugin

service_plugins = router, lbaasv2

I get an error on module import, checking setup.cfg of neutron I see there is no lbaasv2 option.

If I use lbaas and don't touch neutron_lbaas.conf i get

ERROR neutron.services.service_base [req-ac99774a-49e7-45e7-bc6b-b4dcee2b5157 - - - - -] No providers specified for 'LOADBALANCER' service, exiting

if I use baas and this neutron_lbaas (the rest is commented)

service_provider = LOADBALANCERV2:Octavia:neutron_lbaas.drivers.octavia.driver.OctaviaDriver:default

i get

ERROR neutron ConfigFileParseError: Failed to parse /etc/neutron/neutron_lbaas.conf: at /etc/neutron/neutron_lbaas.conf:73, Unexpected continuation line: '  service_provider = LOADBALANCERV2:Octavia:neutron_lbaas.drivers.octavia.driver.OctaviaDriver:default'

Anyway this is my lbaas_agent.ini

[DEFAULT]
# Show debugging output in log (sets DEBUG log level output).
  debug = True

# The LBaaS agent will resync its state with Neutron to recover from any
# transient notification or rpc errors. The interval is number of
# seconds between attempts.
# periodic_interval = 10

# LBaas requires an interface driver be set. Choose the one that best
# matches your plugin.
  interface_driver =neutron.plugins.services.agent_loadbalancer.plugin.LoadBalancerPluginv2



# Example of interface_driver option for OVS based plugins (OVS, Ryu, NEC, NVP,
# BigSwitch/Floodlight)
# interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver

# Use veth for an OVS interface or not.
# Support kernels with limited namespace support
# (e.g. RHEL 6.5) so long as ovs_use_veth is set to True.
# ovs_use_veth = False

# Example of interface_driver option for LinuxBridge
# interface_driver = neutron.agent.linux.interface.BridgeInterfaceDriver

# The agent requires drivers to manage the loadbalancer.  HAProxy is the opensource version.
# Multiple device drivers reflecting different service providers could be specified:
# device_driver = path.to.provider1.driver.Driver
# device_driver = path.to.provider2.driver.Driver
# Default is:
#  device_driver = neutron_lbaas.services.loadbalancer.drivers.haproxy.namespace_driver.HaproxyNSDriver

[haproxy]
# Location to store config and state files
# loadbalancer_state_path = $state_path/lbaas

# The user group
#  user_group = haproxy

# When delete and re-add the same vip, send this many gratuitous ARPs to flush
# the ARP cache in the Router. Set it below or equal to 0 to disable this feature.
# send_gratuitous_arp = 3

----- Found solution ------

Add

device_driver = neutron_lbaas.services.loadbalancer.plugin.LoadBalancerPluginv2

in the neutron.conf like this

device_driver = neutron_lbaas.services.loadbalancer.plugin.LoadBalancerPluginv2
service_plugins = router, neutron_lbaas.services.loadbalancer.plugin.LoadBalancerPluginv2
edit retag flag offensive close merge delete

Comments

Is the neutron-lbaas-agent present in neutron agent-list?

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-12-10 11:24:38 -0500 )edit

Yes but is not alive, i found also that the service neutron-lbaas-agent keeps respawning every few seconds in the syslog

venturozzaccio gravatar imageventurozzaccio ( 2015-12-10 11:44:48 -0500 )edit

Please, answer yourself and mark as correct the answer. Regards

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-12-12 05:37:44 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-12-10 23:13:29 -0500

Prateek K gravatar image

The command that you are using "neutron lbaas-loadbalancer-create" requires lbaasv2 to be installed , it wont work with older lbaas. Check the following :-

  1. In the neutron.conf file what service_plugin you have given.
  2. It should be lbaasv2 and not lbaas
  3. In lbaas_agent.ini what is the service provider. Since lbaas2 octavia is the preffred provider and not HA proxy. Check that.
  4. Finally neutron-lbaas-agent installation is necessary.

If you check all of these and still dont get to anything let me know and in that case also paste the config files and also the output of the command 'dpkg -l | neutron '(For ubuntu) ,, 'rpm -qa |grep neutron'( For RedHat)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-12-10 08:55:27 -0500

Seen: 1,464 times

Last updated: Dec 11 '15