Ask Your Question
0

problem with openstack installation "echo "stack ALL=(ALL) NOPASSWD:ALL" >> /etc/sudoers" [closed]

asked 2015-12-09 03:46:21 -0600

Afnan gravatar image

updated 2015-12-10 03:31:23 -0600

Hi there,

I tried to install openstack on my Laptop by using "All-In-One Single Machine" mode , but I face this problem :

afnan@afnan:~$ echo "stack ALL=(ALL) NOPASSWD:ALL" >> /etc/sudoers
bash: /etc/sudoers: Permission denied

afnan is not the user that I will install openstack on it . I tried the new user but I faces the same problem

Can anyone help me ?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Bipin
close date 2015-12-27 04:32:23.570174

Comments

try the following

sudo echo "stack ALL=(ALL) NOPASSWD:ALL" >> /etc/sudoers

Regards

Bipin gravatar imageBipin ( 2015-12-12 22:11:15 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-12-26 06:33:17 -0600

pl_rock gravatar image

open using command :

sudo visudo

then add line

stack ALL=(ALL) NOPASSWD:ALL

save that file and exit.

edit flag offensive delete link more
1

answered 2015-12-10 05:12:53 -0600

/etc/sudoers can only be acccessed by root.

edit flag offensive delete link more

Comments

it works!

Thank you !

Afnan gravatar imageAfnan ( 2015-12-26 03:32:59 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-12-09 03:46:21 -0600

Seen: 1,739 times

Last updated: Dec 26 '15