Ask Your Question
0

cannot see linux bridge agent running

asked 2015-12-08 12:32:03 -0500

aksan gravatar image

I followed this link to install openstack: http://docs.openstack.org/liberty/ins... . When i do neutron agent-list, i see the agents running on controller node but no linux bridge agent running on compute node. I also tried "service neutron-plugin-linuxbridge-agent status" in the compute node , the command says agent is running. Why i can't see that agent when i run neutron agent-list?

edit retag flag offensive close merge delete

Comments

Check the linuxbridge agent logs. Perhaps it could not connect to rabbit mq server.

mariusleu gravatar imagemariusleu ( 2015-12-08 12:36:03 -0500 )edit

2 answers

Sort by » oldest newest most voted
0

answered 2015-12-12 00:58:50 -0500

Li_He gravatar image

I have same problem with you. and try to follow this http://docs.openstack.org/networking-guide/scenario_legacy_lb.html (http://docs.openstack.org/networking-...) to get linux-bridge-agent of computer node visible. (but it is still xxx instead of act in case, i am trying to find out why)

Compute nodes¶

1.Configure the kernel to enable iptables on bridges and disable reverse path filtering. Edit the /etc/sysctl.conf file:

net.ipv4.conf.default.rp_filter=0 net.ipv4.conf.all.rp_filter=0 net.bridge.bridge-nf-call-iptables=1 net.bridge.bridge-nf-call-ip6tables=1

2.Load the new kernel configuration:

$ sysctl -p

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-12-08 12:32:03 -0500

Seen: 1,302 times

Last updated: Dec 12 '15