Ask Your Question
1

I want to start exploring Neutron Lbaas. Where should I start and how can i install and try it ?

asked 2015-12-07 03:25:25 -0500

Prateek K gravatar image

I want to explore and work on the load balancer side of neutron and also know what components does it use and how it works. Whats the best way to start it

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-12-07 03:42:33 -0500

RHK gravatar image
edit flag offensive delete link more
0

answered 2015-12-07 04:46:01 -0500

dbaxps gravatar image

updated 2015-12-07 05:06:31 -0500

The sequence of steps (Controller/Network Node is a Single Host in HAProxy/Keepalived 3 Node Controller Setup on RDO Liberty ). LBaaS configuration

On each Controller:-
    yum -y install openstack-neutron-lbaas
    openstack-config --set /etc/neutron/neutron.conf DEFAULT service_plugins router,lbaas
    openstack-config --set /etc/neutron/lbaas_agent.ini DEFAULT interface_driver neutron.agent.linux.interface.OVSInterfaceDriver
    openstack-config --set /etc/neutron/lbaas_agent.ini DEFAULT device_driver neutron_lbaas.services.loadbalancer.drivers.haproxy.namespace_driver.HaproxyNSDriver
    openstack-config --set /etc/neutron/lbaas_agent.ini haproxy user_group haproxy

Assuming that /etc/neutron/neutron.conf and /etc/neutron/plugin.ini ( as symlink to /etc/neutron/plugins/ml2/ml2_conf.ini ) are configured properly . On Controller 1

neutron-db-manage --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugin.ini upgrade head

Next

systemctl start neutron-lbaas-agent
systemctl enable neutron-lbaas-agent

I have to notice that Lbaas configuration has to be done prior to running neutron-db-manage . . . . . .

edit flag offensive delete link more

Comments

Hi,

Thanks for the reply but I am facing error while installing the openstack-neutorn-lbaas package as it says there is no such package available. Please note that I am using ubuntu not RDO so there is a change there is a different package required.

Please suggest

Prateek K gravatar imagePrateek K ( 2015-12-08 04:12:17 -0500 )edit

I stay from Ubuntu as far as I can. Sorry.

dbaxps gravatar imagedbaxps ( 2015-12-08 05:40:17 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-12-07 03:25:25 -0500

Seen: 227 times

Last updated: Dec 07 '15