Ask Your Question
0

error installing rdo kilo with proxy

asked 2015-12-05 03:30:41 -0500

bhuvanakrishna gravatar image

I have installed Centos 7 in virtual box. The laptop used proxy to connect to internet. After installing Centos, I have added the "http_proxy","https_proxy" and "no_proxy" environment variables. Every thing works fine, I can access internet through browser, and all commands through command line like "yum", "wget" are also working. But when I install packstack and run "Packstack --allinone" command, I ended up with the following error,

Pre installing Puppet and discovering hosts' details[ ERROR ]

ERROR : Failed to run remote script, stdout: Loaded plugins: fastestmirror, langpacks
Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=7&arch=x86_64&repo=os&infra=stock error was 
14: curl#6 - "Could not resolve host: mirrorlist.centos.org; Unknown error"

stderr: Warning: Permanently added '10.0.2.15' (ECDSA) to the list of known hosts.
+ trap t ERR
+ yum install -y puppet hiera openssh-clients tar nc rubygem-json


One of the configured repositories failed (Unknown),
and yum doesn't have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work "fix" this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Disable the repository, so yum won't use it by default. Yum will then
    just ignore the repository until you permanently enable it again or use
    --enablerepo for temporary usage:

        yum-config-manager --disable <repoid>

 4. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot find a valid baseurl for repo: base/7/x86_64
++ t
++ exit 1

Please check log file /var/tmp/packstack/20151205-041435-Lew9UH/openstack-setup.log for more information
Additional information:
* A new answerfile was created in: /root/packstack-answers-20151205-041437.txt
* Time synchronization installation was skipped. Please note that unsynchronized time on server instances might   be   problem for some OpenStack components.

I have tried putting proxy variable in yum.conf file, if I do that I can't even run yum command. Please help me with this. Thank you.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-02-22 14:57:30 -0500

Hi,

Check if your yum.conf configured OK and the user/password is the right one.

Use this guide to do so: https://docs.openathens.net/display/public/OALA221/Configuring+yum+to+use+a+proxy+server;jsessionid=2F8DD9F1A312D2208A649FA1328304EE

If don't, try with the following steps because maybe packstack internally use sudo to run yum command.

If you set in /etc/sudoers the line with env_keep, sudo commands will have http_proxy environment variables declared.

1- First ensure your user have properly declared http_proxy env variables.

export | grep proxy

You should see your proxy variables on it.

If you use sudo probably you receive an empty response:

sudo env | grep proxy

If it is empy, edit /etc/sudoers file and add the following line

# sudo visudo

Defaults    env_keep += "http_proxy https_proxy no_proxy"

Close your session and login again with the new changes.

Regards.

edit flag offensive delete link more

Comments

I am also facing the same problem. I have installed Centos 7 in virtual box. Proxy sits between the (host and guest OS) to connect to internet. I am able to access Internet from the guest machine,, and all commands through command line like "yum", is also working. Any help will be much appreciated

ankit355 gravatar imageankit355 ( 2017-08-01 09:49:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-12-05 03:30:41 -0500

Seen: 928 times

Last updated: Feb 22 '16