Ask Your Question
0

How to Config nova-network for FlatDHCP with xenserver [closed]

asked 2013-12-12 00:41:58 -0500

adhi gravatar image

updated 2013-12-13 14:28:34 -0500

smaffulli gravatar image

I follow several tutorial on net that explain how to connect nova-compute and nova-network for flatDHCP using XenServer as hypervisor. and here's my configuration on my lab

my config

Question 1 see the picture, whether my connection is correct?

Question 2 I can create instance (cirros) from dashboard and successfully started at xenserver but, the instance couldn't get the IP, here's the instance starting log :

info: initramfs: up at 0.28
GROWROOT: CHANGED: partition=1 start=16065 old: size=64260 end=80325 new: size=2072385,end=2088450
info: initramfs loading root from /dev/xvda1
info: /etc/init.d/rc.sysinit: up at 0.41
[    0.417158] EXT3-fs (xvda1): warning: checktime reached, running e2fsck is recommended
Starting logging: OK
Initializing random number generator... done.
Starting network...
udhcpc (v1.18.5) started
Sending discover...
Sending select for 10.5.5.2...
Sending select for 10.5.5.2...
Sending select for 10.5.5.2...
No lease, failing
WARN: /etc/rc3.d/S40-network failed
cloud-setup: checking http://169.254.169.254/2009-04-04/meta-data/instance-id
wget: can't connect to remote host (169.254.169.254): Network is unreachable
cloud-setup: failed 1/30: up 9.58. request failed
wget: can't connect to remote host (169.254.169.254): Network is unreachable
cloud-setup: failed 2/30: up 10.60. request failed
wget: can't connect to remote host (169.254.169.254): Network is unreachable
........
cloud-setup: failed 30/30: up 38.75. request failed
cloud-setup: after 30 fails, debugging
cloud-setup: running debug (30 tries reached)
############ debug start ##############
### /etc/rc.d/init.d/sshd start
/etc/rc3.d/S45-cloud-setup: line 66: /etc/rc.d/init.d/sshd: not found
route: fscanf
### ifconfig -a
eth0      Link encap:Ethernet  HWaddr FA:16:3E:19:10:E4  
          inet6 addr: fe80::f816:3eff:fe19:10e4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1356 (1.3 KiB)  TX bytes:1792 (1.7 KiB)
          Interrupt:25 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

### route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
route: fscanf
### cat /etc/resolv.conf
cat: can't open '/etc/resolv.conf': No such file or directory
### gateway not found
/etc/rc3.d/S45-cloud-setup: line 66: can't open /etc/resolv.conf: no such file
### pinging nameservers
### uname -a
Linux cirros 3.0.0-12-virtual #20-Ubuntu SMP Fri Oct 7 18:19:02 UTC 2011 x86_64 GNU/Linux
### lsmod
Module                  Size  Used by    Not tainted
vfat                   17585  0 
fat                    61475 ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by adhi
close date 2014-02-17 04:48:42.411705

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-12-13 14:32:18 -0500

smaffulli gravatar image

from the logs it looks like your metadata service is not reacheable. Search this site since this question has been answered other times and there should be enough suggestions for you, too.

edit flag offensive delete link more

Comments

Great, thanks @smaffulli I'll try to search more

adhi gravatar imageadhi ( 2013-12-16 03:38:30 -0500 )edit

Hi @smaffulli, I am very grateful if you would give me a link for question similar to my problem (flatDHC, nova-network, xenserver) because so many question on this site,

adhi gravatar imageadhi ( 2013-12-17 02:58:31 -0500 )edit

Hi adhi, Have you solved this problem? I got the same issue. :( Could you please update your solution here?

Jianbo Zheng gravatar imageJianbo Zheng ( 2015-01-26 10:15:42 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-12-12 00:41:58 -0500

Seen: 505 times

Last updated: Dec 13 '13