Ask Your Question
0

cannot ping 203.0.113.101 icehouse

asked 2015-12-03 04:02:35 -0500

Emad gravatar image

updated 2015-12-05 07:31:31 -0500

Hi

I followed OpenStack icehouse installation guide (http://docs.openstack.org/icehouse/install-guide/install/apt/openstack-install-guide-apt-icehouse.pdf (here)), However I am not able to ping 203.0.113.101

This is my Controller ifconfig:

eth0      Link encap:Ethernet  HWaddr 52:54:00:2d:d9:90  
          inet addr:10.0.0.11  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::5054:ff:fe2d:d990/64 Scope:Link
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:15201 errors:0 dropped:1034 overruns:0 frame:0
          TX packets:10282 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:17043137 (17.0 MB)  TX bytes:1660709 (1.6 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:38658 errors:0 dropped:0 overruns:0 frame:0
          TX packets:38658 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:8819118 (8.8 MB)  TX bytes:8819118 (8.8 MB)

controller /etc/network/intefaces:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
up ifconfig eth0 promisc
address 10.0.0.11
netmask 255.255.255.0
network 10.0.0.0
gateway 10.0.0.1
broadcast 10.0.0.255
dns-nameservers 8.8.8.8

Network node ifconfig:

br-ex     Link encap:Ethernet  HWaddr d2:a0:4e:2d:c5:4d  
          inet6 addr: fe80::f843:8aff:fe2f:bd6/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:14 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1156 (1.1 KB)  TX bytes:648 (648.0 B)

br-int    Link encap:Ethernet  HWaddr b6:fa:c8:a4:32:48  
          inet6 addr: fe80::8460:15ff:fe98:f0eb/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:21 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1722 (1.7 KB)  TX bytes:648 (648.0 B)

br-tun    Link encap:Ethernet  HWaddr d2:db:b4:d3:46:4e  
          inet6 addr: fe80::68ca:15ff:fe84:8394/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:648 (648.0 B)

eth0      Link encap:Ethernet  HWaddr 52:54:00:3c:6e:b2  
          inet addr:10.0.0.21  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::5054:ff:fe3c:6eb2/64 Scope:Link
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:5076 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4343 errors:0 dropped:0 ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-12-03 05:19:43 -0500

dbaxps gravatar image

updated 2015-12-05 12:24:02 -0500

UPDATE 12/05/2015
On your system :-

network@network-std:~$ sudo ip netns exec qrouter-77934cd9-0b07-47b2-8aae-2357b4e8d72f ifconfig
         Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1344 (1.3 KB)  TX bytes:1344 (1.3 KB)

qg-351a2628-cc Link encap:Ethernet  HWaddr fa:16:3e:26:d2:7f  
          inet addr:203.0.113.101  Bcast:203.0.113.255  Mask:255.255.255.0
          inet6 addr: fe80::f816:3eff:fe26:d27f/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:3 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:264 (264.0 B)  TX bytes:738 (738.0 B)

qr-55cf3209-02 Link encap:Ethernet  HWaddr fa:16:3e:66:31:32  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::f816:3eff:fe66:3132/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:3 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:210 (210.0 B)  TX bytes:906 (906.0 B)

and

 auto br-ex
    iface br-ex inet static
    up ifconfig br-ex promisc
    address 203.0.113.101
    netmask 255.255.255.0
    gateway 203.0.113.1
    dns-nameservers 8.8.8.8

qg-351a2628-cc  and  br-ex has same IP 203.0.113.101. Please , change br-ex IP to 203.0.113.107

END UPDATE

UPDATE
You wrote "So now I can ping 203.0.113.101 from network node but not from controller or compute node."

That is what is supposed to happen, you are not supposed to have Ethernet interface belongs External network
on  Controller or Compute. Would you like plugin one more NIC on Controller put it on External Net and ping
203.0.113.101 as much as you want. All set.

END UPDATE

Ethernet interface eth2 has to be configured ( via /etc/network/interfaces ) as OVS port (promiscuous mode) of OVS bridge br-ex. The last one should have any available IP belongs external network ( a kind of 203.0.113.0/24 not sure about your CIDR)

If neutron router was setup properly, the qg-xxxxx interface should be ping able from qdhcp-namespace.
Mistake in neutron router commands setting external gateway and internal interface might result this failure.
As well as wrong status of port providing interface to internal subnet.

-------------------------------------------------------------------------------------------------------------------------------------------------

File /etc/neutron/plugins/ml2/openvswitch_agent.ini (Liberty version name) should have entry 
     bridge_mappings =physnet1:br-ex

Final conclusion system - in meantime has wrong OVS configuration on Network Node, which breaks in/outbound connectivity. Your routing table on Network Node demonstrates it pretty clear

In ...

(more)
edit flag offensive delete link more

Comments

okay in icehouse it seems that openvswitch_agent.ini is called ml2_conf.ini. So I added bridge_mappings =physnet1:br-ex on network node, and after ifconfig I get 2 more interfaces: phy-br-ex and int-br-ex however still can't ping 203.0.113.101

Emad gravatar imageEmad ( 2015-12-03 06:17:18 -0500 )edit

It's ovs_neutron_plugin.ini or you need declare [ovs] section in ml2_conf.ini. However, looks like you skipped core notices. Setup OVS port eth2 and OVS bridge br-ex having IP on external net. Post again:-

$ route -n

on Network Node.

dbaxps gravatar imagedbaxps ( 2015-12-03 06:41:43 -0500 )edit

I put an update at the end of my post

Emad gravatar imageEmad ( 2015-12-03 08:24:09 -0500 )edit

That is what is supposed to happen, you are not supposed to have Ethernet interface belongs External network on Controller or Compute. Would you like plugin one more NIC on Controller put it on External Net and ping 203.0.113.101 as much as you want. All set.

dbaxps gravatar imagedbaxps ( 2015-12-03 09:02:52 -0500 )edit

See, attentively picture I posted. It's classic 3 node design. Neither one of Controller nor Compute have NICs on External network

dbaxps gravatar imagedbaxps ( 2015-12-03 09:07:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-12-03 04:02:35 -0500

Seen: 271 times

Last updated: Dec 05 '15