Ask Your Question
1

Horizon VNC not working

asked 2015-12-02 08:48:07 -0500

bhuvanakrishna gravatar image

I have installed openstack using RDO on centos vm. I created a cirros instance and assigned a floating ip to it. When clicked on console menu, I am getting an error message "The server closed the connection without sending any data". I have added port forwarding rules 80 and 6080. Please help me with this. I have tried googling but it didn't help. Thank you.

edit retag flag offensive close merge delete

Comments

When you see the option 'open console on new window' right click on it and there will be an option to copy link location.

Copy that link in a notepad or something and see the IP which it is using. Is that ip accessable from your system ? ... If not correct it in the nova.conf as suggested by others

Prateek K gravatar imagePrateek K ( 2015-12-03 01:22:58 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-12-02 12:17:21 -0500

kuldeep_verma gravatar image

I was also facing the same problem while loging to VNC console. I make the following changes in nova.conf file which is in /etc/nova directory and it works fine for me.Here in my case RDO is insatalled on 10.10.20.2

vnc_enabled = True vncserver_listen = 0.0.0.0 vncserver_proxyclient_address = 10.10.20.2 novncproxy_base_url = http://10.10.20.2:6080/vnc_auto.html

and Make sure, if u r using virtual box..promiscuous mode should be on.

With Regards, Kuldeep

edit flag offensive delete link more
0

answered 2015-12-02 10:00:28 -0500

capsali gravatar image

updated 2015-12-03 08:48:50 -0500

You most probably have a misconfigured nova.conf under [vnc]. Check again nova.conf from controller and compute node. Check if vnc proxy is running on the controller node and check the logs aswell. And ofcourse check ports on controller and compute nodes so they are opened.

This is as much as i could tell you right now without further investigation on your side. Eventually provide vnc proxy log, apache2 error logs and access logs!

NoVNC consists of two parts : VNC proxy that resides on the controller node that clients connect interact with and actual VNC server that resides on the compute nodes. When a client openes a novnc connection it connects to proxy server that gets a connection address from the compute node. In your case both reside on the allinone node.

You should have these setting under /etc/nova/nova.conf file :

[vnc]
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = <node_ip_address>
novncproxy_base_url = http://<node_ip_address>:6080/vnc_auto.html

I haven't actually played with an allinone installation but it shouuld be the same. You should look under apache logs for the exact error. And ofcourse under /var/log/nova for proxy errors.

edit flag offensive delete link more

Comments

I have installed allinone packstack. Would you please elaborate your answer since I am a beginner I couldn't get you.

bhuvanakrishna gravatar imagebhuvanakrishna ( 2015-12-02 10:42:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-12-02 08:48:07 -0500

Seen: 1,880 times

Last updated: Dec 03 '15