Ask Your Question
1

vif_type=binding_failed and can't launch instances. Error message : Could not clean up failed build, not rescheduling

asked 2015-12-02 08:25:52 -0500

Fairness gravatar image

updated 2015-12-04 03:08:49 -0500

Hi everyone, i work on openSUSE 13.2 and i installed openstack (KILO version) on it.

I have 4 nodes :

  • controller
  • compute
  • networkg
  • storage( with glance)

The problem is that i can't launch instances... i have this error message : Build of instance "$UUID" aborted: Could not clean up failed build, not rescheduling. All my service run normally but in my DB neutron, in the table "ml2_port_bindings" it tell me vif_type = binding_failed. So i think the probleme is from the network node... my log file doesn't tell me anything about this problem except the file "/var/log/neutron/neutron-openvswitch-agent.log" which tell me : " Device $UUID not defined on plugin"

Did anyone had this problem ? In my network node, i have only 2 interfaces, not 3.

Need help, please tell me if you need more information about my environment ..

Thank you in advance

[ml2] type_drivers = flat,vlan,gre,vxlan tenant_network_types = gre mechanism_drivers = openvswitch [ml2_type_flat] flat_networks = external [ml2_type_vlan] [ml2_type_gre] tunnel_id_ranges = 1:1000 [ml2_type_vxlan] [securitygroup] enable_security_group = True enable_ipset = True firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver [ovs] local_ip = 10.200.202.17 bridge_mappings = external:br-ex [agent] tunnel_types = gre [database] connection = mysql://neutron:openstack@controller/neutron

NEUTRON_SYSCONFIG=/etc/sysconfig/neutron DAEMON="openvswitch-agent" USER="neutron" CONFFILE="/etc/neutron/neutron.conf" RUNDIR="/var/run/neutron" NEUTRON_PLUGIN_CONF="/etc/neutron/plugins/ml2/ml2_conf.ini" NEUTRON_OPT_CONFFILES="" if [ -n "$NEUTRON_PLUGIN_CONF" ] ; then PLUGIN_ARGS="--config-file=$NEUTRON_PLUGIN_CONF" fi if [ -n "$NEUTRON_OPT_CONFFILES" ]; then for f in $NEUTRON_OPT_CONFFILES; do if [ -r "$f" ]; then PLUGIN_ARGS+=" --config-file=$f" fi done fi mkdir -p $RUNDIR && chown $USER. $RUNDIR . /etc/rc.status case "$1" in start) echo -n "Starting neutron-$DAEMON" /sbin/startproc -q -s -u $USER /usr/bin/neutron-$DAEMON --config-file=$CONFFILE $PLUGIN_ARGS rc_status -v ;; stop) echo -n "Shutting down neutron-$DAEMON" /sbin/killproc /usr/bin/neutron-$DAEMON rc_status -v ;; restart) $0 stop $0 start rc_status ;; force-reload) $0 try-restart rc_status ;; reload) echo -n "Reload service neutron-$DAEMON" rc_failed 3 rc_status -v ;; status) echo -n "Checking for service neutron-$DAEMON" /sbin/checkproc /usr/bin/neutron-$DAEMON rc_status -v ;; try-restart|condrestart) if test "$1" = "condrestart"; then echo "${attn} Use try-restart ${done}(LSB)${attn} rather than condrestart ${warn}(RH)${norm}" fi $0 status if test $? = 0; then $0 restart else rc_reset # Not running is not a failure. fi rc_status # Remember status and be quiet ;; *) echo "Usage: $0 {start|stop|status|try-restart|restart|force-reload|reload}" exit 1 ;; esac rc_exit

enter code here
edit retag flag offensive close merge delete

Comments

What is value of bridge_mapping in openvswitch_agent.ini or OVS section of ml2_plugin.ini ?

dbaxps gravatar imagedbaxps ( 2015-12-03 02:47:53 -0500 )edit

in which node? In network node : [ovs] local_ip = x.x.x.x bridge_mappings = external:br-ex

nothing in compute node. Thank you a lot for your answer.

Fairness gravatar imageFairness ( 2015-12-03 07:41:59 -0500 )edit

On any node :-

bridge_mappings =physnet1:br-ex
dbaxps gravatar imagedbaxps ( 2015-12-03 08:19:47 -0500 )edit

ok, i did it on the 2 nodes , but the problem is still there.. :/ Thanks for your answer

Fairness gravatar imageFairness ( 2015-12-03 08:24:50 -0500 )edit
1

Please, add to question:-

ml2_conf.ini
openvswitch_agent.ini

on Network Node

dbaxps gravatar imagedbaxps ( 2015-12-03 08:50:38 -0500 )edit

3 answers

Sort by » oldest newest most voted
0

answered 2015-12-03 01:28:41 -0500

check your "/etc/neutron/plugins/ml2/ml2_conf.ini" and /etc/neutron/neutron.conf.
It maybe related to the driver configuration in ml2_conf.ini:
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

edit flag offensive delete link more

Comments

hi, thank you for your answer.

My driver configuration is OK :/

so the problem isn't from this... Thank you again for your answer

enter code here
Fairness gravatar imageFairness ( 2015-12-03 02:50:29 -0500 )edit
0

answered 2015-12-03 01:50:41 -0500

Bipin gravatar image

Hello,

Edit /etc/neutron/plugins/ml2/ml2_conf.ini on both compute and network node

Change

‘tunnel_type = gre’ to ‘tunnel_types = gre’

And Restart the services.

COMPUTE NODE

service openvswitch  restart
service neutron-openvswitch-agent restart

NEUTRON NODE

service neutron-openvswitch-agent restart
service neutron-l3-agent restart
service neutron-dhcp-agent restart
service neutron-metadata-agent restart

Regards

edit flag offensive delete link more

Comments

Hi, thank you fo your answer.

There was already an "s" at "types" in my conf , so the problem isn't from this.

Thank you again for your answer.

Fairness gravatar imageFairness ( 2015-12-03 02:47:49 -0500 )edit
0

answered 2015-12-03 01:20:31 -0500

VonGoofy gravatar image

Check your neutron configuration files especially ml2_conf.ini and your chosen neutron plugin configuration.

I had the same problem when upgrading to liberty and didn't notice that all openvswitch configuration in ml2 switched to a dedicated configuration in ml2 folder.

So this is most likely a configuration problem in neutron.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-12-02 08:25:52 -0500

Seen: 1,594 times

Last updated: Dec 04 '15