Ask Your Question
0

When verifying operation after installing the neutron service, I don't see the linuxbridge agent running from my compute node.

asked 2015-12-01 13:27:48 -0500

cjhall4 gravatar image

I checked to see if the service was running using "$ status neutron-plugin-linuxbridge-agent" and it was but I don't see it when I run "$ neutron agent-list". I'm very new to this so let me know what other info you may need and I'll add it as quickly as possible.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-12-02 08:03:10 -0500

I'm guessing you are running the "status neutron-plugin-linuxbridge-agent" on your compute node, not the controller and it is running. If that's the case and neutron agent-list isn't showing anything, it means the agent does not communicate with the controller (the process is running on your compute node but it doesn't know where to connect to the controller or another similar issue). Can you check the neutron-linuxbridge-agent logs (on the compute node) ? Can you also check if you have the correct setting in /etc/neutron/neutron.conf on the controller node (the sections [keystone_authtoken] and the rabbit or qpid settings (whichever message bus you are using) ?

edit flag offensive delete link more

Comments

The logs indicate that there is "No module named rabbit". I've tried to fix this by making sure pyrabbit was installed but I'm still getting the same thing after restarting services. I've verified the neutron settings on the controller node and they are all what the install guide say to make them.

cjhall4 gravatar imagecjhall4 ( 2015-12-08 14:24:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-12-01 13:08:22 -0500

Seen: 350 times

Last updated: Dec 02 '15