Ask Your Question
0

How to enable SNAT after disable it

asked 2015-11-29 07:16:46 -0500

senyapsudah gravatar image

Hi Guys,

i'm looking for a way to enable back SNAT on my router. previously i did disable it on my router using --disable-snat. please advise how can i achieved this?

thanks.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-11-29 11:07:10 -0500

dbaxps gravatar image

updated 2015-11-29 11:27:40 -0500

I would try

$ neutron router-gateway-clear Router01
$ neutron router-interface-delete Router01 <interface> 
$ neutron router-delete Router01
$ neutron router-create Router02
$ neutron router-gateway-set Router02  public ( the same which was cleared by (1))
$ neutron router-gateway-add Router02 <interface> ( the same which was deleted by (2))

Due to syntax

neutron router-gateway-set --disable-snat <Router ID> <External network ID>

It might be enough clear external gateway and set it again not touching interface to private subnet

edit flag offensive delete link more

Comments

thanks for the suggestion. i'm thinking to do that also. however, if i clear the gateway, i will not be able to get the same ip again. as currently i route my public ip from my ISP router directly to the virtual router IP. or will i be able to set the router IP using the same IP that i use current?

senyapsudah gravatar imagesenyapsudah ( 2015-11-30 06:47:20 -0500 )edit

It depends on how you setup external network.Please, post ovs-vsctl show && ifconfig on Network Node.

dbaxps gravatar imagedbaxps ( 2015-11-30 09:48:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-11-29 07:16:46 -0500

Seen: 1,368 times

Last updated: Nov 29 '15