Ask Your Question
0

packstack installation error

asked 2015-11-28 20:01:57 -0500

nag gravatar image

updated 2015-12-01 08:58:49 -0500

pl_rock gravatar image

Hi,

During installation of kilo version openstack with packstack, installation fails. This worked fine before and now i see following error:

# packstack --allinone

..............
..............
Adding Nagios server manifest entries                [ DONE ]
Adding Nagios host manifest entries                  [ DONE ]
Adding post install manifest entries                 [ DONE ]
Copying Puppet modules and manifests                 [ DONE ]
Applying 10.145.97.29_prescript.pp
**10.145.97.29_prescript.pp:                        [ ERROR ]          
Applying Puppet manifests                         [ ERROR ]
ERROR : Error appeared during Puppet run: 10.145.97.29_prescript.pp
Error: Could not find data item CONFIG_USE_SUBNETS in any Hiera data file and no default supplied at /var/tmp/packstack/411b335d189547d0a93244a99360bbce/manifests/10.145.97.29_prescript.pp:2 on node controller2**
You will find full trace in log /var/tmp/packstack/20151128-174957-PuR2aZ/manifests/10.145.97.29_prescript.pp.log
Please check log file /var/tmp/packstack/20151128-174957-PuR2aZ/openstack-setup.log for more information
Additional information:
 * A new answerfile was created in: /root/packstack-answers-20151128-174958.txt
 * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
 * File /root/keystonerc_admin has been created on OpenStack client host 10.145.97.29. To use the command line tools you need to source the file.
 * To access the OpenStack Dashboard browse to http://10.145.97.29/dashboard .
Please, find your login credentials stored in the keystonerc_admin in your home directory.
 * To use Nagios, browse to http://10.145.97.29/nagios username: nagiosadmin, password: 9ee1442847c049fb

log file shows:

log file /var/tmp/packstack/20151128-175216-RbPIAg/openstack-setup.log for more information
Could not find data item CONFIG_USE_SUBNETS in any Hiera data file and no default supplied at /var/tmp/packstack/5ce0d19d6f20484f84503ef0f8509d25/manifests/10.145.97.28_prescript.pp:2 on node localhost
edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2015-11-29 01:39:54 -0500

dbaxps gravatar image
edit flag offensive delete link more
1

answered 2015-11-28 20:41:48 -0500

pl_rock gravatar image

This is a bug see here:

https://bugzilla.redhat.com/show_bug.cgi?id=1284978

go through it and try suggested solution.

edit flag offensive delete link more
0

answered 2015-11-30 01:50:49 -0500

Prateek K gravatar image

As its a bug you can look for the solution in the bugzilla page. However if you just dont care about the network provisioning that packstack does by default and want to just install openstack then do the following.

  1. Generate an answer file via command - packstack --gen-answer-file /root/myfile

  2. open the answer file.

  3. there would be an option by the name of PROVISION_NETWORK(PUBLIC/PRIVATE), or something similar I am forgetting the exact variable name(That you can figure out I guess).

  4. Set it to false.

  5. Start the deployment via command 'packstack --answer-file /root/myfile'

This would create an openstack environment but will not create any networks that come by default in neutron(Private/Public), So you will actually bypass this bug

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-11-28 20:01:57 -0500

Seen: 1,413 times

Last updated: Dec 01 '15