Ask Your Question
1

Liberty: The request you have made requires authentication. (HTTP 401)

asked 2015-11-28 11:49:42 -0500

davidyuan gravatar image

I am aware that the same question has be asked on previous releases. I still can not figure out how to fix mine. I follow the instructions to install keystone (http://docs.openstack.org/liberty/ins...). Failed to create service entity with the following command:

ubuntu@stratus1:~$ openstack service create --name keystone --description "OpenStack Identity" --os-url http://controller:35357/v3 --os-token c01f11a39faceecde032 --os-identity-api-version 3 identity
The request you have made requires authentication. (HTTP 401) (Request-ID: req-ac8744cd-0551-422d-affb-313ee985e0d3)

/var/log/keystone/keystone.log complains about invalid token.

2015-11-27 21:19:00.605 28217 WARNING keystone.middleware.core [req-b4daadb2-65cb-41c9-84e2-1722b7139376 - - - - -] RBAC: Invalid token
2015-11-27 21:19:00.606 28217 WARNING keystone.common.wsgi [req-b4daadb2-65cb-41c9-84e2-1722b7139376 - - - - -] The request you have made requires authentication.
2015-11-27 21:19:00.607 28217 INFO eventlet.wsgi.server [req-b4daadb2-65cb-41c9-84e2-1722b7139376 - - - - -] 127.0.0.1 - - [27/Nov/2015 21:19:00] "POST /v3/services HTTP/1.1" 401 425 0.078863

I double-checked what I put in /etc/keystone/keystone.conf. I also dropped and recreated keystone database in mysql.

ubuntu@stratus1:~$ sudo cat /etc/keystone/keystone.conf | grep admin_token
#admin_token = ADMIN
admin_token = c01f11a39faceecde032
ubuntu@stratus1:~$

Where should I check next? What did I do wrong? Thanks in advance.

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2015-11-28 21:46:53 -0500

Bipin gravatar image

Hello,

Can you debug the request, which will give you detailed explanation of the issue

openstack service create --debug
edit flag offensive delete link more
0

answered 2015-11-29 08:23:04 -0500

davidyuan gravatar image

Thanks for the tips. The cause of the problem was that port 5000 was taken by another process. apache2 was not able to bind properly. Once that got sorted out, the rest of the steps to configure keystone went smoothly.

edit flag offensive delete link more
0

answered 2016-02-17 15:14:38 -0500

Muad_dib gravatar image

Hi,

I have the same error The request you have made requires authentication. HTTP 401

I have Centos7, disabled SELinux & firewalld.

I am using: http://docs.openstack.org/liberty/install-guide-rdo/keystone-services.html (http://docs.openstack.org/liberty/ins...)

I run:

openstack service create --debug --name keystone --description "OpenStack Identity" identity

I see:

    ...
        RESP BODY: {"error": {"message": "The request you have made requires authentication.","code": 401, "title": "Unauthorize"}}
    ....

Request returned failure status: 401

I have got only httpd running.

netstat -tulpn 
tcp6     0       0  :::35357                :::*        LISTEN                  1947/httpd
tcp6     0       0  :::5000                 :::*        LISTEN                  1947/httpd

According to http://docs.openstack.org/liberty/install-guide-rdo/keystone-install.html (Liberty Installation Guide) only httpd service should be started. I have tried to start openstack-keystone.service unfortunately it cannot be started - the port is already assigned to httpd.

I have exported

export OS_TOKEN=294a4c8a8a475f9b9836      #the same as in /etc/keystone/keystone.conf
export OS_URL=http://controller:35357/v3
export OS_IDENTITY_API_VERSION=3

I can manually login into mysql using user keystone with password configured in /etc/keystone/keystone.conf

I look forward for suggestions how to fix the bug.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2015-11-28 11:49:42 -0500

Seen: 12,673 times

Last updated: Nov 29 '15