Ask Your Question
1

packstack fails to install openstack-keystone (pyOpenSSL-0.13.1-1.el6.x86_64 requires openssl 1.0.1)

asked 2013-12-11 11:51:25 -0500

ale gravatar image

updated 2013-12-11 11:56:41 -0500

Hello, running packstack --allinone on fresh install of CentOS 6.4, I get the following error:

ERROR : Error appeared during Puppet run: 10.21.1.4_keystone.pp
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-keystone' returned 1: Error: Package: pyOpenSSL-0.13.1-1.el6.x86_64 (openstack-havana)
You will find full trace in log /var/tmp/packstack/20131211-182129-5I0avV/manifests/10.21.1.4_keystone.pp.log

Checking the trace file the problem is the package pyOpenSSL-0.13.1-1.el6.x86_64 (required by openstack-keystone) that depends on OpenSSL 1.0.1

Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-keystone' returned 1: Error: Package: pyOpenSSL-0.13.1-1.el6.x86_64 (openstack-havana)
           Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit)
Error: Package: pyOpenSSL-0.13.1-1.el6.x86_64 (openstack-havana)
           Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
Error: Package: pyOpenSSL-0.13.1-1.el6.x86_64 (openstack-havana)
           Requires: libssl.so.10(libssl.so.10)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Centos 6.4 is still using OpenSSL 1.0.0

[root@n04 ~]# rpm -q openssl
openssl-1.0.0-27.el6.x86_64

Does pyOpenSSL-0.13.1-1.el6.x86_64 have been updated in the havana repo since the last 2 weeks? Because about 2 weeks ago I successfully installed Openstack Havana with packstack --allinonce on a CentOS 6.4 server.

Thanks you

edit retag flag offensive close merge delete

Comments

I am seeing the same error when I do 1) yum install -y http://rdo.fedorapeople.org/openstack-havana/rdo-release-havana.rpm 2) yum update I am running this on RHEL 6.4

sayaji15 gravatar imagesayaji15 ( 2013-12-11 14:21:14 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
2

answered 2013-12-11 17:23:50 -0500

I've pushed out an update to openssl to the RDO repos to cater for RHEL/Centos 6.4 systems. I've verified that python-swiftclient-1.8.0 now installs on a RHEL6.4 based system Guards have been put in place to ensure this doesn't happen again

edit flag offensive delete link more

Comments

Thank you very much. Now it's working.

ale gravatar imageale ( 2013-12-12 07:10:31 -0500 )edit
0

answered 2013-12-11 16:24:13 -0500

sgordon gravatar image

A fix/update to python-swiftclient was pushed into RDO a few days ago, it required pyOpenSSL-0.13. In turn pyOpenSSL-0.13 requires openssl-1.0.1 which is in RHEL/CentOS 6.5 but not 6.4 (as you have discovered). Hopefully one of the RDO packaging folk respond with the way forward here.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-12-11 11:51:25 -0500

Seen: 903 times

Last updated: Dec 11 '13