Ask Your Question
0

ERROR oslo.messaging._drivers.impl_rabbit [req-b15a657e-8c7a-486d-9a80-7f6013724353 ] AMQP server on controller:5672 is unreachable: [Errno 113] EHOSTUNREACH. [closed]

asked 2015-11-25 15:31:42 -0600

Luci gravatar image

I am installing Juno version on three nodes namely controller, compute, networking nodes (All are Centos 7). when I am trying to run "systemctl start libvirtd.service openstack-nova-compute.service " its not starting. I checked the nov-compute.log but I am unable to understand the error. Rabbitmq is running on controller node.

2015-11-25 16:07:55.488 4307 INFO oslo.messaging._drivers.impl_rabbit [req-b15a657e-8c7a-486d-9a80-7f6013724353 ] Delaying reconnect for 1.0 seconds...
2015-11-25 16:07:56.489 4307 INFO oslo.messaging._drivers.impl_rabbit [req-b15a657e-8c7a-486d-9a80-7f6013724353 ] Connecting to AMQP server on controller:5672
2015-11-25 16:07:56.507 4307 ERROR oslo.messaging._drivers.impl_rabbit [req-b15a657e-8c7a-486d-9a80-7f6013724353 ] AMQP server on controller:5672 is unreachable: [Errno 113] EHOSTUNREACH. Trying again in 17 seconds.
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Luci
close date 2015-11-26 18:51:00.655126

3 answers

Sort by ยป oldest newest most voted
1

answered 2015-11-25 23:57:26 -0600

Prateek K gravatar image

RabbitMQ makes a TCP connection, so my suggestion would be to see if iptables or any firewall is blocking it to make connections. If there is a switch in the topology then there can be a possibility that the switch might dropping the packets.

Secondly Try pinging the controller via its host name from compute node. There is a possibility that the IP of the controller node is not set right in the /etc/hosts file of the compute node.

Finally try to see the status of rabbitMQ on the controller node, weather its running as a server on the controller node and listing to the requests.

Probably you will get the conclusion after this.

edit flag offensive delete link more

Comments

Thanks a lot for educating me on RabbitMQ. After Installing Telnet also it was not working. The culprit was iptables.

Luci gravatar imageLuci ( 2015-11-26 18:37:31 -0600 )edit
1

answered 2015-11-25 21:53:12 -0600

Bipin gravatar image

Hello,

Most probably RMQ is not running on the controller, or there is a communcation issue between your compute node and controller node. Give the output of the following

netstat -ntlp | grep 5672 (From the controller node)

telnet controller 5672 (From compute node)

Regards

edit flag offensive delete link more

Comments

Now its working. Telnet was not installed on my nodes. Thanks a Ton..

Luci gravatar imageLuci ( 2015-11-26 18:35:58 -0600 )edit
0

answered 2015-11-26 18:44:42 -0600

Luci gravatar image

After installing Telnet also I still faced the same issue. The issue was with ipatbles, before starting the OpenStack installation I deactivated iptables (service iptables stop) as mentioned in the OpenStack installation guide from http://www.openstack.org. I was reading a blog were I came across that stopping and flushing (iptables --flush) differ. I taught stop the ipatbles would do the work, Even though I stopped the iptables service, It only worked after I flushed the iptables.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-11-25 15:31:42 -0600

Seen: 8,919 times

Last updated: Nov 26 '15