Ask Your Question
0

setting up user accounts to use openstack [closed]

asked 2013-12-11 09:38:44 -0500

KeithJ gravatar image

Openstack version : FOLSOM Linux b3dbm2 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Hi I have set up some user_accounts so that our openstack administrators can use their own account. Currently we are all using the openstack account, which is creating issues as different people like to customise their .profile according to their preferences.

Ifr I log in as openstack and run $ nova list --all-tenants I get a list of tenants returned.

However if I run as myself , I get the following returned.

ERROR: Invalid OpenStack Nova credentials.

My profile already has the following set up.

export OS_TENANT_NAME= export OS_USERNAME= export OS_PASSWORD= export OS_AUTH_URL=

What else do I need to do to get this work correctly

thanks in advance

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by dheeru
close date 2013-12-12 11:51:24.607678

Comments

To confirm, you are currently sharing a linux shell account called `openstack`. This account has a `.profile` file with the various `OS_*` variables exported that allow you to access OpenStack as a user called `openstack`?

jtopjian gravatar imagejtopjian ( 2013-12-11 17:29:03 -0500 )edit

I have set up separate accounts for admin users. These accounts have been set up on the same machine that the openstack account is on. Essentially I want these users to be able to run any openstack command successfully, rather than everybody having their own openstack account. The .profile and .bashrc have the correct configuration. When I try and issue the nova list --all-tenants commands in debug mode I get unauthorised. Which is presumably why the comamnd above shows ERROR: Invalid OpenStack Nova credentials.

KeithJ gravatar imageKeithJ ( 2013-12-12 03:46:46 -0500 )edit

OK, so you have several linux shell accounts that will be sharing the same openstack account? If so, then the OS_* vars should be the same in everyone's .profile. If you're getting unauthorized for one user but not another, then there's a difference in the OS_ vars.

jtopjian gravatar imagejtopjian ( 2013-12-12 09:17:14 -0500 )edit

Thankyou - I made a mistake. I had the os_username set to openstack instead of admin. It works now

KeithJ gravatar imageKeithJ ( 2013-12-12 09:32:38 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2013-12-11 10:04:42 -0500

dheeru gravatar image
1. Run you command with --debug option. It will give hint on the credentials used.
2. OS_TENANT_NAME etc may not be valid. Not sure OS is prepended for these variables in falsom.
3. For commands, you can pass -os-username, os-tenant-name etc as command line options itself. 

All this may help you to find the solution for your problem.
edit flag offensive delete link more
1

answered 2013-12-12 09:34:27 -0500

KeithJ gravatar image

These settings must be set in your login (eg .profile or .bashrc) and should be the same values that are used in the openstack account

export OS_TENANT_NAME=<> export OS_USERNAME=<> export OS_PASSWORD=<> export OS_AUTH_URL=<>

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-12-11 09:38:44 -0500

Seen: 862 times

Last updated: Dec 12 '13