Ask Your Question
0

compute_nodes tables does not get populated with numa_topology information in Liberty

asked 2015-11-24 07:09:03 -0500

sbezverk gravatar image

updated 2015-11-24 08:35:19 -0500

Hello team,

I am running Liberty (latest RDO rpms) on a RHEL 7.2 I noticed that compute_nodes table in nova does not have any information wrt to numa topology:

select numa_topology from compute_nodes;

+---------------+

| numa_topology |

+---------------+

| NULL |

+---------------+

1 row in set (0.00 sec)

<topology>
 <cells num="2">
 <cell id="0"> <memory unit="KiB">134108916</memory> <cpus num="16">
 <cell id="1"> <memory unit="KiB">134217728</memory> <cpus num="16">
 </topology>

numactl --hardware

available: 2 nodes (0-1) 
node 0 cpus: 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 
node 0 size: 130965 MB node 0 free: 113289 MB 
node 1 cpus: 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 
node 1 size: 131072 MB node 1 free: 113879 MB 
node distances: node 0 1

rpm -qa *qemu-kvm*

qemu-kvm-common-1.5.3-105.el7.x86_64 qemu-kvm-1.5.3-105.el7.x86_64

Any thought why would it be the case?? Thank you

Serguei

edit retag flag offensive close merge delete

Comments

What reports:-

numactl --hardware
virsh capabilities

add as UPDATE 1 to question

dbaxps gravatar imagedbaxps ( 2015-11-24 07:36:24 -0500 )edit

Thank you for looking into this issue, appreciate it a lot. All numa related information ok as other software discovers it. Example openvswitch sees 2 numa nodes, here is requested info. Next comment with requested info:

sbezverk gravatar imagesbezverk ( 2015-11-24 07:57:08 -0500 )edit

numactl --hardware available: 2 nodes (0-1) node 0 cpus: 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 node 0 size: 130965 MB node 0 free: 113289 MB node 1 cpus: 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 node 1 size: 131072 MB node 1 free: 113879 MB node distances: node 0 1

sbezverk gravatar imagesbezverk ( 2015-11-24 07:57:27 -0500 )edit

<topology> <cells num="2"> <cell id="0"> <memory unit="KiB">134108916</memory> <cpus num="16"> <cell id="1"> <memory unit="KiB">134217728</memory> <cpus num="16">

As you can see numa info is avaialble, but not in compute_node table.

sbezverk gravatar imagesbezverk ( 2015-11-24 07:59:52 -0500 )edit

What reports rpm -qa \*qemu-kvm\* ?

dbaxps gravatar imagedbaxps ( 2015-11-24 08:27:46 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-11-24 08:39:15 -0500

dbaxps gravatar image

updated 2015-11-24 09:00:21 -0500

Per your answer

rpm -qa *qemu-kvm*

qemu-kvm-common-1.5.3-105.el7.x86_64 qemu-kvm-1.5.3-105.el7.x86_64

This is the case to work with NumaTopology on RHEL 7.X you have to activate some optional channel to install:- (like on CentOS 7.X I need qemu-kvm-ev-2.1.2-23.el7.1)

   Red Hat Enterprise Linux OpenStack Platform 7.0 for RHEL 7:

    x86_64:
    libcacard-rhev-2.1.2-23.el7_1.9.x86_64.rpm
    libcacard-tools-rhev-2.1.2-23.el7_1.9.x86_64.rpm
    qemu-img-rhev-2.1.2-23.el7_1.9.x86_64.rpm
    qemu-kvm-common-rhev-2.1.2-23.el7_1.9.x86_64.rpm
    qemu-kvm-rhev-2.1.2-23.el7_1.9.x86_64.rpm
    qemu-kvm-rhev-debuginfo-2.1.2-23.el7_1.9.x86_64.rpm
    qemu-kvm-tools-rhev-2.1.2-23.el7_1.9.x86_64.rpm
edit flag offensive delete link more

Comments

No, I do not have them installed as they are not part of RHEL 7.2 distribution, the distribution comes with 1.5.3, they also did not get installed during Liberty installation as these rpms are not part of RDO. I will try to get them from my official RH Kilo distribution and see. Thank you.

sbezverk gravatar imagesbezverk ( 2015-11-24 08:58:08 -0500 )edit

They are , just escalate to RHN managers and ask which channel you need to activate to set up
qemu-kvm-rhev (RH Enterprise Virtualization)

dbaxps gravatar imagedbaxps ( 2015-11-24 09:03:13 -0500 )edit

You were 100% right, I got these RPMs from Centos repo (2.3.0) version and I do see now, the table get properly populated.

Thank you very much and say Hi to Rostov-on-Don for me :-) have not been there for almost 10 years.

sbezverk gravatar imagesbezverk ( 2015-11-24 09:46:51 -0500 )edit

Hi dbxps, sbezvek I followed all the steps, still it shows NULL fom me. I deleted the nova database, recreated it, and did nova db-manage..that didn't help either. Please help me. Set up details : CentOS7.2, OpenStack Liberty

pjb gravatar imagepjb ( 2016-05-18 06:36:20 -0500 )edit

@pjbI had this same issue. It looks like the problem was that qemu-system-x86 version 2.0.0 was being pulled in as well, and this was causing the _has_numa_support check to fail here: https://github.com/openstack/nova/blob/master/nova/virt/libvirt/driver.py#L5147 (https://github.com/openstack/nova/blo...). Try yum remove qemu-system-x86

kevinbringard gravatar imagekevinbringard ( 2016-10-04 14:50:37 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-11-24 07:09:03 -0500

Seen: 320 times

Last updated: Nov 24 '15