Ask Your Question
1

Problems with Liberty package repository under Ubuntu 14.04

asked 2015-11-24 00:12:50 -0500

Herr-Herner gravatar image

updated 2015-11-24 09:29:53 -0500

We are using Ubuntu Server 14.04.3 that uses Apt 1.0.1. We strictly follow the instructions and add the Liberty package repository:

apt-get install software-properties-common
add-apt-repository cloud-archive:liberty

and run

apt-get update

We are getting the following error:

W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: You may want to run apt-get update to correct these problems

The error comes definetly from the Liberty package repository. With the help of Google, we found out that the problem should disappear by upgrading Apt to >=1.0.7.

We don't want to do that, because of missing repositories containing Apt >=1.0.7 packages for Trusty.

Can we simply ignore the problem? Are there any recommendations?

edit retag flag offensive close merge delete

Comments

I have the same issue installing the cloud-archive Liberty to the fresh Ubuntu 14.04.3 installation. I hope that since majority of the community use Ubuntu this issue was already seen of pointed? However if I am right this problem is also reported in Bug#1511462 i launchpad.. Any advise??

ying-yang gravatar imageying-yang ( 2015-11-27 07:24:35 -0500 )edit

Well i too had this error when upgraded from kilo to liberty but the upgrade process went well.

capsali gravatar imagecapsali ( 2015-11-28 05:04:21 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-11-29 08:57:56 -0500

I Have the same problem I'm using ubuntu 14.04 lts I strictly follow the instructions and add the Liberty package repository!!!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

4 followers

Stats

Asked: 2015-11-24 00:12:50 -0500

Seen: 1,117 times

Last updated: Nov 24 '15