Unable to ping the gateway

asked 2015-11-23 07:30:57 -0600

heena gravatar image

Hi, I am trying to install openstack. While I created the bridge file, I am not able to ping anything now except loopback address. Here are my config files

ip a s
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eno16777736: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP qlen 1000
    link/ether 00:0c:29:1e:e3:64 brd ff:ff:ff:ff:ff:ff
    inet 192.168.72.141/24 brd 192.168.72.255 scope global dynamic eno16777736
       valid_lft 432sec preferred_lft 432sec
    inet6 fe80::20c:29ff:fe1e:e364/64 scope link
       valid_lft forever preferred_lft forever
3: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN
    link/ether 3e:b9:07:bb:ee:f5 brd ff:ff:ff:ff:ff:ff
4: br-ex: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether 00:0c:29:1e:e3:64 brd ff:ff:ff:ff:ff:ff
    inet 192.168.72.137/24 brd 192.168.72.255 scope global br-ex
       valid_lft forever preferred_lft forever
    inet6 fe80::20c:29ff:fe1e:e364/64 scope link
       valid_lft forever preferred_lft forever
5: br-int: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN
    link/ether 2a:58:be:b5:1d:45 brd ff:ff:ff:ff:ff:ff
6: br-eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN
    link/ether 1e:1e:de:c5:0b:46 brd ff:ff:ff:ff:ff:ff



cat /etc/hosts
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6


cat /etc/resolv.conf
# Generated by NetworkManager
search localdomain cloud9.com
nameserver 192.168.254.254

I have my another server configuration as controller node

ip a s
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:0c:29:83:cd:fe brd ff:ff:ff:ff:ff:ff
    inet 192.168.72.142/24 brd 192.168.72.255 scope global dynamic eth1
       valid_lft 1450sec preferred_lft 1450sec
    inet6 fe80::20c:29ff:fe83:cdfe/64 scope link
       valid_lft forever preferred_lft forever

I tried to make an eth1 ethernet card. but according to below status, I got it all wrong.

ovs-vsctl show
1beba460-fe81-42c9-a69f-45a73c61d03d
    Bridge br-ex
        Port br-ex
            Interface br-ex
                type: internal
        Port "eno16777736"
            Interface "eno16777736"
    Bridge br-int
        fail_mode: secure
        Port "int-br-eth1"
            Interface "int-br-eth1"
                type: patch
                options: {peer="phy-br-eth1"}
        Port br-int
            Interface br-int
                type: internal
    Bridge "br-eth1"
        Port "br-eth1"
            Interface "br-eth1"
                type: internal
        Port "eth1"
            Interface "eth1"
                error: "could not ...
(more)
edit retag flag offensive close merge delete

Comments

heena , I did not go through the entire logs but one thing i know is that when you add bridge to a port its connectivity , goes out. To get the connectivity back , you need to assign IP to the bridge , if needed, and assign 0.0.0.0 ip to Eth port. Check the route as well

ritesh.singh.aricent@gmail.com gravatar imageritesh.singh.aricent@gmail.com ( 2015-11-24 05:41:59 -0600 )edit