Ask Your Question
0

packstack fails to detect ipaddress of interface eth1

asked 2015-11-21 04:41:54 -0500

theillien gravatar image

I'm trying to add a node to my single-server installation using the instructions at https://www.rdoproject.org/install/adding-a-compute-node/ (https://www.rdoproject.org/install/ad...). After editing the answer file I run packstack --answer-file=~/<answerfile> as per the instructions. However, it fails on the line

Adding Neutron API manifest entries

The error is

ERROR : "Couldn't detect ipaddress of interface eth1 on node 192.168.122.151"

I tried to find a solution but the only thing I came across is another answer here on the Q&A (https://ask.openstack.org/en/question/79980/packstack-complains-of-not-being-able-to-detect-ipaddress-of-interface/ (https://ask.openstack.org/en/question...)). I tried the solution that is suggested by sanderv but it didn't do anything. I got the same error.

One thing I've found with the instructions is that they mention CONFIG_NOVA_COMPUTE_HOSTS and CONFIG_NOVA_NETWORK_HOSTS stating that the IPs should be properly configured. Neither of those keys is in the answer file that packstack generated. I have CONFIG_COMPUTE_HOSTS and CONFIG_NETWORK_HOSTS, though. Each of these I've set to be what the instructions say the other keys should be.

In addition to this issue (or maybe as a result of it), the interface values I set are wiped out. For instance, I set CONFIG_NOVA_COMPUTE_PRIVIF and CONFIG_NOVA_NETWORK_PRIVIF to eth1 as instructed. But after running packstack --answer-file=<answerfile> those are blank.

What am I doing wrong?

edit retag flag offensive close merge delete

Comments

Have you assigned static IP to eth1 on 192.168.122.151 before running packstack ?

dbaxps gravatar imagedbaxps ( 2015-11-21 11:00:53 -0500 )edit

192.168.122.151 is on the control node public (eth0) interface. 192.168.122.152 is the compute node public (eth0) interface which I assign in the answer file to CONFIG_COMPUTE_HOSTS. The private (eth1) interface is assigned in the answer file per the instructions.

theillien gravatar imagetheillien ( 2015-11-21 13:44:39 -0500 )edit

Perhaps the instructions are unclear as to which IP to use?

theillien gravatar imagetheillien ( 2015-11-21 13:44:45 -0500 )edit

It is a bug, please report it.

mpa360 gravatar imagempa360 ( 2015-11-28 08:10:34 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-11-21 14:25:23 -0500

theillien gravatar image

updated 2015-11-21 15:18:18 -0500

I appears that I added the controller host's IP to the EXCLUDE_SERVERS key at some point. I removed that and the installation went off without a hitch.

Additionally, http://tuxlabs.com/?p=151 (these) instructions were clearer even though they are more or less identical. The main difference is that they use the actual keys (CONFIG_COMPUTE_HOSTS and CONFIG_NETWORK_HOSTS) rather than nonexistent keys (CONFIG_NOVA_COMPUTE_HOSTS and CONFIG_NOVA_NETWORK_HOSTS).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-11-21 04:41:54 -0500

Seen: 1,400 times

Last updated: Nov 21 '15