"410 gone" in ceilometer with gnocchi backend

asked 2015-11-20 06:37:15 -0500

ke liang gravatar image

updated 2015-11-20 08:16:15 -0500

I have installed gnocchi on my devtstack(stable/liberty) at single node. I have encountered an issue with the "ceilometer meter-list" command.As well as Dashboard got meter data failed with same issue.

Error messages are follow:

   DEBUG (v2) Making authentication request to http://10.211.55.12:5000/v2.0/tokens
   DEBUG (connectionpool) "POST /v2.0/tokens HTTP/1.1" 200 4567
   DEBUG (client) REQ: curl -g -i -X 'GET' 'http://10.211.55.12:8777/v2/meters' -H 'User-Agent:        ceilometerclient.openstack.common.apiclient' -H 'X-Auth-Token: {SHA1}5e9657a33d5859b737f38eae556e3bcbe900f4fb'
   INFO (connectionpool) Starting new HTTP connection (1): 10.211.55.12
   DEBUG (connectionpool) "GET /v2/meters HTTP/1.1" 410 348
   DEBUG (client) RESP: [410] {'Content-Length': '348', 'Keep-Alive': 'timeout=5, max=100', 'Server': 'Apache/2.4.7 (Ubuntu)', 'Connection': 'Keep-Alive', 'Date': 'Fri, 20 Nov 2015 09:16:41 GMT', 'Content-Type': 'application/json', 'x-openstack-request-id': 'req-e6a47fd6-138a-4321-ba21-5fe54c28f51b'}

    DEBUG (client) RESP BODY: {"error_message": "<html>\n <head>\n  <title>410 Gone</title>\n </head>\n <body>\n  <h1>410 Gone</h1>\n  This resource is no longer available. No forwarding address is given.<br /><br />\nThis telemetry installation is configured to use Gnocchi. Please use the Gnocchi API available on the metric endpoint to retrieve data.\n\n\n </body>\n</html>"}

my devstack localrc file with enable_server

  disable_service n-net
  disable_service ceilometer-alarm-evaluator,ceilometer-alarm-anotification
  ENABLED_SERVICES=rabbit,mysql,key
  ENABLED_SERVICES+=,horizon
  ENABLED_SERVICES+=,n-api,n-crt,n-obj,n-cpu,n-cond,n-sch,n-novnc,n-cauth
  ENABLED_SERVICES+=,g-api,g-reg
  ENABLED_SERVICES+=,q-svc,q-agt,q-dhcp,q-l3,q-meta,q-metering,neutron
  ENABLED_SERVICES+=,cinder,c-api,c-vol,c-sch,c-bak
  enable_plugin ceilometer git://git.openstack.org/openstack/ceilometer
  ENABLED_SERVICES+=,ceilometer-acompute,ceilometer-acentral,ceilometer-collector,ceilometer-api,ceilometer-anotification

  enable_plugin gnocchi https://github.com/openstack/gnocchi master
  enable_service gnocchi-api,gnocchi-metricd

  enable_plugin aodh https://git.openstack.org/openstack/aodh master
  ENABLED_SERVICES+=,aodh-evaluator,aodh-notifier,aodh-api
  ENABLED_SERVICES+=,s-proxy,s-object,s-container,s-account
  SWIFT_HASH=66a3d6b56c1f479c8b4e70ab5c2000f5
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-02-25 04:56:00 -0500

yprokule gravatar image
  1. This happens when just gnocchi dispatcher is configured.
  2. U have use gnocchi's client to retrieve metrics from gnocchi backend.

Not sure how to configured this with devstack.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-11-20 06:37:15 -0500

Seen: 899 times

Last updated: Feb 25 '16