Ask Your Question
0

No handlers could be found for logger "oslo_config.cfg"

asked 2015-11-20 02:44:03 -0500

prapul gravatar image

updated 2015-11-20 03:03:19 -0500

Hi All ,

Start working on liberty with centos7-controller node when i try to Populate the Identity service  got the bellow error please some one suggest me.

note- the same problem in ubuntu 14.04 also....

command ------ su -s /bin/sh -c "keystone-manage db_sync" keystone error----- No handlers could be found for logger "oslo_config.cfg"

note only Keystone all the services getting the same error while populating the service.

Thanks , Prapul Sriram.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-11-26 06:17:16 -0500

andr gravatar image

updated 2015-11-30 06:59:27 -0500

Same issue, why no replies still? Also cent7 x86_64, I've done literally everything that could potentially come to your mind or is google'able, would require several hours to describe all I did including code modification attempts.

su -s /bin/sh -c "keystone-manage db_sync" keystone

No handlers could be found for logger "oslo_config.cfg"

openstack service create --name keystone --description "OpenStack Identity" identity

Internal Server Error (HTTP 500)

logs do not provide any useful info, even increasing level to its maximum:

2015-11-26 15:13:43.973796 No handlers could be found for logger "oslo_config.cfg" 2015-11-26 15:13:44.094941 mod_wsgi (pid=4278): Target WSGI script '/usr/bin/keystone-wsgi-admin' cannot be loaded as Python module. 2015-11-26 15:13:44.095023 mod_wsgi (pid=4278): Exception occurred processing WSGI script '/usr/bin/keystone-wsgi-admin'. 2015-11-26 15:13:44.095042 Traceback (most recent call last): 2015-11-26 15:13:44.095076 File "/usr/bin/keystone-wsgi-admin", line 36, in <module> 2015-11-26 15:13:44.095096 application = initialize_admin_application() 2015-11-26 15:13:44.095103 File "/usr/lib/python2.7/site-packages/keystone/server/wsgi.py", line 78, in initialize_admin_application 2015-11-26 15:13:44.095115 return initialize_application('admin') 2015-11-26 15:13:44.095122 File "/usr/lib/python2.7/site-packages/keystone/server/wsgi.py", line 64, in initialize_application 2015-11-26 15:13:44.095147 startup_application_fn=loadapp) 2015-11-26 15:13:44.095155 File "/usr/lib/python2.7/site-packages/keystone/server/common.py", line 51, in setup_backends 2015-11-26 15:13:44.095165 res = startup_application_fn() 2015-11-26 15:13:44.095174 File "/usr/lib/python2.7/site-packages/keystone/server/wsgi.py", line 61, in loadapp 2015-11-26 15:13:44.095184 'config:%s' % config.find_paste_config(), name) 2015-11-26 15:13:44.095191 File "/usr/lib/python2.7/site-packages/keystone/config.py", line 91, in find_paste_config 2015-11-26 15:13:44.095247 raise exception.ConfigFileNotFound(config_file=paste_config_value) 2015-11-26 15:13:44.095470 ConfigFileNotFound: An unexpected error prevented the server from fulfilling your request.

30.10.2015: Ok, reinstalled minimal CentOS Linux release 7.1.1503 (Core). Disabled/removed all "useless" services/pckgs, such as postfix and alikes, just in case. Followed fresh install guide for liberty release. On the database population step still got "No handlers could be found for logger "oslo_config.cfg"" even tho the DB itself got populated successfully, just as before. But this time service creation went all well and I expect the upcoming procedures to succeed as well, will keep you up to date, since developers don't seem to be trying to produce problematic environments and test it for us. What else I did prior to install: added secondary addresses to whichever your preferable i-face name happen to be, such as "ifcfg-enp2s0f0:1" for ex; added route-iface with all routes I need; configured /etc/hosts ofc; implicitly specified "GATEWAYDEV=enp2s0f0" @network file; disabled selinux completely; didn't install openstack-selinux at all; used ntpdate and cron instead of chrony(I still think you'd be better off using chrony tho); disabled NM !!! additionally set "nm controlled" to OFF just to be supersure for all i-faces ... (more)

edit flag offensive delete link more

Comments

confirmed .

Thomas Li gravatar imageThomas Li ( 2016-04-14 06:00:16 -0500 )edit
0

answered 2015-12-04 08:39:19 -0500

Noah gravatar image

Might not work for everyone but the solution here was editing the /etc/hosts file and adding "controller" to the 127.0.0.1 line

I actually read this on an other Forum or such don't remeber URL so all credit goes to that guy !!

Liberty Standard install with Ubuntu 15.10 MariaDB

edit flag offensive delete link more

Comments

not working

Thomas Li gravatar imageThomas Li ( 2016-04-14 05:24:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2015-11-20 02:44:03 -0500

Seen: 4,152 times

Last updated: Nov 30 '15