Can't connect to VM

asked 2015-11-18 09:41:36 -0500

alf gravatar image

updated 2015-11-18 17:25:12 -0500

Hi,

I'm new to Openstack. I installed it on a single node, single NIC Fedora 21 system using IceHouse. I followed the instructions listed in this website: http://www.server-world.info/en/note?os=Fedora_21&p=openstack_juno&f=8 (link text)

I manage to make Keystone, Nova and Glance run and I can even instantiate a VM but I can't ssh to it.

+--------------------------------------+------------+--------+------------+-------------+--------------------+ | ID | Name | Status | Task State | Power State | Networks | +--------------------------------------+------------+--------+------------+-------------+--------------------+ | 8a19898b-2e56-49a9-8dc4-ec6ab90659fd | Ubuntu1410 | ACTIVE | - | Running | network01=10.1.0.2 | +--------------------------------------+------------+--------+------------+-------------+--------------------+

The following bridge and tap are created. And when I tcpdump the tap or the bridge I can see that packets are being received. However, when I SSH or ping the VM I'm getting 'No route to host' error.

So what I am doing wrong?


br100: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.1.0.1  netmask 255.255.255.0  broadcast 10.1.0.255
        inet6 fe80::fc16:3eff:fe87:9271  prefixlen 64  scopeid 0x20<link>
        ether fe:16:3e:87:92:71  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 107  bytes 17122 (16.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vnet0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::fc16:3eff:fe87:9271  prefixlen 64  scopeid 0x20<link>
        ether fe:16:3e:87:92:71  txqueuelen 500  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
edit retag flag offensive close merge delete

Comments

Have you added the security group rules for SSH and ICMP?

redondo-mk gravatar imageredondo-mk ( 2015-11-18 12:44:51 -0500 )edit

Hi,

You mean something like this?

nova secgroup-add-rule default tcp 22 22 0.0.0.0/0

nova secgroup-add-rule default icmp -1 -1 0.0.0.0/0

Yes, I have.

alf gravatar imagealf ( 2015-11-18 17:20:47 -0500 )edit

I figured it out. It seems it's an image problem. The one I downloaded seems is not booting properly, I replaced it with a new image from the link the openstack website suggested and now I can ping the instance.

alf gravatar imagealf ( 2015-11-21 08:43:05 -0500 )edit