Ask Your Question
0

Error on tenant administration on Horizon dashboard

asked 2013-05-07 08:02:46 -0600

epillet gravatar image

Hi,

Using Horizon with Grizzly on Ubuntu 10.04, I am facing a problem when I try to manage the tenants (named "projects" on the dashboard). I get a red tooltip with

Error: An error occurred. Please try again.

I have no error in the logs... at least not in /var/nova/*

The only lines that got printed are theses ones (in : nova-api.log)

2013-05-07 14:36:53.479 2779 INFO nova.osapicompute.wsgi.server [-] (2779) accepted ('127.0.0.1', 43578) 2013-05-07 14:36:53.548 INFO nova.osapicompute.wsgi.server [req-778d7fc5-6fe0-436e-98af-b5e975f827ee 0bbd68ad830f4bc982bd51389a85f82d 3603dbf8c95646f989235e6d3d0e401d] 127.0.0.1 "GET /v2/3603dbf8c95646f989235e6d3d0e401d/os-quota-sets/3603dbf8c95646f989235e6d3d0e401d/defaults HTTP/1.1" status: 200 len: 495 time: 0.0683880

But I can create, delete and edit them using keystone commands.

So... Where could I get any more details/logs about this error ? Any clue about a solution ?

Thanks for any help !

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
3

answered 2013-05-07 08:33:38 -0600

jpichon gravatar image

updated 2013-05-07 08:39:26 -0600

If this is an error in Horizon, you want to look at the Apache error logs, probably under /var/log/apache2 in Ubuntu. There should be a stack trace that will give more information.

Considering the screen you're talking about, I think perhaps this is due to the default role not existing in keystone. In local_settings.py there is a OPENSTACK_KEYSTONE_DEFAULT_ROLE variable for the default role assigned to members, check that this role also exists in Keystone.

Hope this helps!

edit flag offensive delete link more

Comments

o_O How did you do this ?

Problem solved, thank you !

epillet gravatar imageepillet ( 2013-05-07 08:52:05 -0600 )edit

Haha, glad this helped! I may have been working on https://bugs.launchpad.net/horizon/+bug/1175165 recently, which is why this is fresh in my mind ;)

jpichon gravatar imagejpichon ( 2013-05-07 08:56:02 -0600 )edit

Ok, not so magical after all, :) but still impressive !

epillet gravatar imageepillet ( 2013-05-07 09:15:34 -0600 )edit

guys, i can see this OPENSTACK_KEYSTONE_DEFAULT_ROLE in /opt/stack/horizon/openstack_dashboard/local (local_settings.py) and adding a project still gives me the same error, what should i do?

HussamBk gravatar imageHussamBk ( 2017-03-11 09:55:11 -0600 )edit
1

answered 2014-03-14 18:29:19 -0600

cloudyz gravatar image

This just bit me, to be clear to those dense like me (this worked on CentOS:

  • Check /etc/openstack-dashboard/local_settings for OPENSTACK_KEYSTONE_DEFAULT_ROLE = "Member" it should be there. The error happens because the role does not exist in keystone.
  • Check for "Member" on Keystone: keystone role-list. If Member is not there, create it.
  • Create Member role in Keystone: keystone role-create --name Member

Done:

Tell tale in apache error_log

[error] NotFound: Could not find default role "Member" in Keystone
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-05-07 08:02:46 -0600

Seen: 3,218 times

Last updated: Mar 14 '14