Ask Your Question

liberty Self-service bridge can't build

asked 2015-11-17 01:05:15 -0500

Eggy gravatar image

updated 2015-11-17 01:29:49 -0500

I use VMware workstation12 to build openstack. And I got a problem about building the bridge with Networking Option 2: Self-service networks. I don't know how to edit /etc/neutron/plugins/ml2/linuxbridge_agent.ini ( openstack docs said Replace PUBLIC_INTERFACE_NAME with the name of the underlying physical public network interface. and Replace OVERLAY_INTERFACE_IP_ADDRESS with the IP address of the underlying physical network interface that handles overlay networks. The example architecture uses the management interface.

I don't understand it.

my setting is like this (image description)

I set local_ip with the VM's IP itself.

and I list my neutron component , it didn't show bridge. (image description)

do anyone know what should I set in PUBLIC_INTERFACE_NAME and OVERLAY_INTERFACE_IP_ADDRESS?

edit retag flag offensive close merge delete


anyone can help?

Eggy gravatar imageEggy ( 2015-11-19 08:31:18 -0500 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2015-11-17 19:19:15 -0500

Eggy gravatar image

anyone can help?

edit flag offensive delete link more

answered 2015-12-15 23:53:08 -0500

VincentW gravatar image

I also meet this issue. what I do is that I set the PUBLIC_INTERFACE_NAME with the management interface name and set the OVERLAY_INTERFACE_IP_ADDRESS withe the management interface ip address. then I assign the floating ip to the vm. hope it can help on this.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2015-11-17 01:05:15 -0500

Seen: 310 times

Last updated: Dec 15 '15