How to set MTU of tap interfaces?

asked 2015-11-16 20:30:37 -0500

leonshaw gravatar image

I'm using kilo under ubuntu14.04-server, ML2 OVS plugin and vxlan setup. And trying to enable jubmo frames for instances. I've set the parameters in ml2_conf.ini:

[ml2]
...
path_mtu = 9000
segment_mtu = 9000
...
[agent]
tunnel_types = vxlan
veth_mtu = 9000

I've also changed the MTU of physical tunnel source interfaces on all hosts. I created a network and the MTU is correct(8950). But when launching instances, the tap interfaces attached to br-int still has MTU 1500. After setting it to 8950, everything works fine. So could I assume that the MTU value isn't passed to libvirt? Is there any way to enable it? Thanks.

edit retag flag offensive close merge delete

Comments

leonshaw gravatar imageleonshaw ( 2015-11-20 03:08:08 -0500 )edit