Ask Your Question
0

Neutron: Can't ping internet from instance and router namespace

asked 2015-11-16 19:37:34 -0600

dbblackdiamond gravatar image

Hi,

I have been trying to configure an openstack kilo environment based on 4 virtual machines with the following network configuration:

  • Controller01: external ip 192.168.1.135, management ip 192.168.50.135, tunnel ip 192.168.60.135
  • Compute01: external ip 192.168.1.136, management ip 192.168.50.136, tunnel ip 192.168.60.136
  • Compute02: external ip 192.168.1.140, management ip 192.168.50.140, tunnel ip 192.168.60.140
  • Network01: no external ip as per installation guide, management ip 192.168.50.137, tunnel ip 192.168.60.137. The external interface is eth1

My issue is that I can't ping the internet or outside world from the instances or from the router namespace. My instance subnet is 10.10.10.0. My qrouter has 2 interfaces: 10.10.10.1 and 192.168.1.160.

From an instance, I can ping 10.10.10.1, 192.168.1.160 but not my default gateway, which is 192.168.1.1 or anything else on the 192.168.1.x network. From the instance, I can also ping another instance and from the namespace of the qrouter, I can ping the instance as well.

Here are some information from Network01:

root@network01:~# ip netns
qdhcp-5c2bd816-81b9-4c42-acf5-3103fdceabed
qrouter-88baa567-97f2-48be-883c-a7ae389a60c5

root@network01:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 08:00:27:40:7d:2a brd ff:ff:ff:ff:ff:ff
    inet 10.0.2.15/24 brd 10.0.2.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:27ff:fe40:7d2a/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 08:00:27:6c:6f:1a brd ff:ff:ff:ff:ff:ff
    inet6 fe80::a00:27ff:fe6c:6f1a/64 scope link 
       valid_lft forever preferred_lft forever
4: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 08:00:27:4c:b3:63 brd ff:ff:ff:ff:ff:ff
    inet 192.168.50.137/24 brd 192.168.50.255 scope global eth2
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:27ff:fe4c:b363/64 scope link 
       valid_lft forever preferred_lft forever
5: eth3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 08:00:27:7f:46:a3 brd ff:ff:ff:ff:ff:ff
    inet 192.168.60.137/24 brd 192.168.60.255 scope global eth3
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:27ff:fe7f:46a3/64 scope link 
       valid_lft ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-11-17 06:50:31 -0600

Herman Ge gravatar image

In /etc/neutron/l3_agent.ini, set external_network_bridge=br-ex. Then restart related services.

edit flag offensive delete link more

Comments

Hi, Thanks a lot for the response. I have just done that, restarted the services and even rebooted the virtual machines and it still doesn't work.

dbblackdiamond gravatar imagedbblackdiamond ( 2015-11-17 10:47:17 -0600 )edit

what is the output of ovs-vsctl show and which neutron services are running on each node..

smcas gravatar imagesmcas ( 2015-11-17 22:50:59 -0600 )edit
0

answered 2015-11-18 00:08:14 -0600

dbblackdiamond gravatar image

Hi,

I have actually figured it out after much searching and head-scratching. The VMs Openstack is installed into are running in VirtualBox and by default, VirtualBox doesn't allow Promiscuous Mode on the VM network adapters. Once I set my external network adapter to allow Promiscuous Mode, it all started to work fine.

Thanks a lot for the responses. Bertrand.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-11-16 19:37:34 -0600

Seen: 948 times

Last updated: Nov 18 '15