Error Sahara create cluster: 'Error attach volume to instance [closed]

asked 2015-11-16 08:23:30 -0500

Aimar47 gravatar image

Hi all,

When trying to create a new Hadoop Cluster using Sahara in OpenStack, we ended up by the following debug error trace in sahara api log file:

2015-10-05 06:31:18.917 3139 ERROR sahara.context [-] Thread 'attach-volumes-for-instance Hadoop-Cluster Hadoop-Master-Node-001' fails with exception: 'Error attach volume to instance Hadoop-Cluster-Hadoop-Master-Node-001'
2015-10-05 06:31:18.953 3139 ERROR sahara.context [-] Thread 'attach-volumes-for-ng-Hadoop-Master-Node' fails with exception: 'An error occurred in thread 'attach-volumes-for-instance-Hadoop-Cluster-Hadoop-Master-Node-001': Error attach volume to instance Hadoop-Cluster-Hadoop-Master-Node-001'

2015-10-05 06:31:39.659 3139 ERROR sahara.context [-] Thread 'attach-volumes-for-ng-Hadoop-Worker-Node' fails with exception: 'An error occurred in thread 'attach-volumes-for-instance-Hadoop-Cluster-Hadoop-Worker-Node-001': Error attach volume to instance Hadoop-Cluster-Hadoop-Worker-Node-001'
2015-10-05 06:31:41.613 3139 ERROR sahara.context [-] Thread 'cluster-creating-d8d21ee9-03f1-4a26-90de-b534a6cb5fc5' fails with exception: 'An error occurred in thread 'attach-volumes-for-ng-Hadoop-Master-Node': An error occurred in thread 'attach-volumes-for-instance-Hadoop-Cluster-Hadoop-Master-Node-001': Error attach volume to instance PP-Hadoop-Cluster-Hadoop-Master-Node-001'

What looks strange that the templates both in Master and Worker nodes have not been configured to use cinder volumes and they suppose to create ephemeral disks as default storage option.

The Implementation is configured to create a Hadoop Cluster within Vanilla 2.3.0 in Icehouse release (RDO installation) The status of the cluster in Sahara is looping on 'Waiting' status and finished by Error. Image used is ubuntu vanilla from Mirantis sahara file repository with a medium flavor per instance (2 VCPUs, 40 GB Disk and 4 GB RAM)

Googling was not really helping this time. Does anyone has faced such error in Sahara ?

Thanks in advance !

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rbowen
close date 2016-08-18 13:44:51.541634

Comments

Can it be hardware capabilities issues ? I am running RDO allinone installation with 14GB RAM and 8 cores.

Aimar47 gravatar imageAimar47 ( 2015-11-17 02:18:42 -0500 )edit

I see that you've tagged the post with 'icehouse'. I'm closing it 'oudated', because Icehouse is EOL. However, if you are still experiencing this problem with a more recent version, please do reopen with updated info. Thanks.

rbowen gravatar imagerbowen ( 2016-08-18 13:44:46 -0500 )edit