Ask Your Question
1

port not usable for instance - interface-attach

asked 2015-11-13 05:10:19 -0500

santhosh thatipaly gravatar image

While trying to Attach Interfaces using the os-interfaces REST API I'm getting below exception.

Port 5cd5ed53-7924-4876-8aa8-2e6ccadcb21d not usable for instance 87565ada-2f75-4d8f-a47a-655c20a01967

I'm not sure what wrong I'm doing here. I checked the nova and neutron logs for more stack trace but I could not find any log messages for my operation.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
4

answered 2016-06-09 02:53:41 -0500

eblock gravatar image

I just had the same issue, found out that I had a mismatch between my environment scripts. Make sure you assign the correct project/tenant IDs, domain IDs and network IDs for the right user. I had tried to assign the port to a project ID that has no access to that network.

control1:~ # env | grep "OS_"
OS_PROJECT_DOMAIN_ID=default
OS_PROJECT_ID=90c403f317ee47feb0dad58461e76fb1
OS_IMAGE_API_VERSION=2
OS_USER_DOMAIN_ID=default
OS_IDENTITY_API_VERSION=3
OS_AUTH_URL=http://control1:35357/v3
OS_USERNAME=admin

It's been a while since this question was posted, but I hope this helps anyway.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2015-11-13 05:10:19 -0500

Seen: 2,238 times

Last updated: Jun 09 '16