Ask Your Question
0

External dns resolution

asked 2015-11-09 14:09:37 -0500

varesa gravatar image

My instances can't resolve any external hostnames, only the host-__.openstacklocal names (so the dns server works). Connecting by IP works.

I've added

dnsmasq_dns_servers =192.168.0.201

to /etc/neutron/dhcp_agent.ini, where 192.168.0.201 is my dns server.

The openstack host (and the instance) can access the dns server.

What's wrong?

edit retag flag offensive close merge delete

Comments

Instances can access the server, but what is in the instance's /etc/resolv.conf? Did you restart the dhcp agent, and did you start the instance after restarting the agent? You might also want to check for information in the console log.

Bernd Bausch gravatar imageBernd Bausch ( 2015-11-10 11:05:39 -0500 )edit

@BerndBausch resolv.conf has nameserver 192.168.88.0. That is the beginning of my allocation pool for the subnet. I have restarted the agent and even the whole host to make sure. Which console log? The instance? Neutron?

varesa gravatar imagevaresa ( 2015-11-10 11:59:27 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-11-10 13:10:46 -0500

varesa gravatar image

The issue didn't have anything to do with OpenStack. My local bind host I was trying to use was set to only accept connections from a too tight subnet so it refused to answer queries.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-11-09 14:08:21 -0500

Seen: 530 times

Last updated: Nov 10 '15