Ask Your Question
1

How to disable DEBUG on qpid logging

asked 2013-12-10 13:34:59 -0600

cgirda gravatar image

I built a multinode havana cluster with neutron. Everything looks good except for a noise logs filled with qpid DEBUG messages. Causing to fill the /var/log on the controller and compute nodes. How can I disable this DEBUG options for qpid services

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-01-29 10:36:04 -0600

Joseph Kubik gravatar image

updated 2014-01-29 10:37:10 -0600

Another solution, as seen here: (https://bugzilla.redhat.com/show_bug.cgi?id=1047849)

Edit nova.conf and change the default_log_levels=... line to look like this: default_log_levels=amqplib=WARN,sqlalchemy=WARN,boto=WARN,suds=INFO,keystone=INFO,eventlet.wsgi.server=WARN,qpid=INFO

edit flag offensive delete link more
1

answered 2013-12-10 13:36:38 -0600

cgirda gravatar image

updated 2013-12-10 13:37:16 -0600

Resolved by switching the following 2 options in nova.conf to false.

Print debugging output (set logging level to DEBUG instead of default WARNING level). (boolean value)

debug=false

Print more verbose output (set logging level to INFO instead of default WARNING level). (boolean value) verbose=false

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-12-10 13:34:59 -0600

Seen: 560 times

Last updated: Jan 29 '14