Ask Your Question
0

fuel-plugin deployment problem

asked 2015-11-06 23:08:33 -0600

Maple Wang gravatar image

Hi,

I'm trying to deploy some fuel-plugins in my mirantis openstack environment. but, once I install the fuel plugins, then provisioning of OS during deployment always fail(log shows that there is no response from mcollective agent on the nodes), as long as I removed these plugins, everything works fine.

I googled a little, find maybe that's because the nodes have no or limited internet access, and deployment of fuel-plugin may require internet access to download additional package, is that true?

I'm using fuel 7.0(ubuntu 14.04), and I use the local mirror(fuel-createmirror) and install the plugins including zabbix, LMA collector, elasticsearch/kibana and influxdb. for some reason, in my environment, only http request can go through the proxy, but https request can't.

so I want to ask, is it necessary for fuel 7.0 to get internet access for environment when deploy plugins? if my environment must behind the proxy, how to set it to let fuel use it when deploying plugins.

best regards.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-11-07 23:43:33 -0600

Bipin gravatar image

Hi,

Fuel Master need Internet access to install plugins.

Regards

edit flag offensive delete link more

Comments

thanks for reply, do you mean that it is not necessary to have internet access for other nodes during deployment , only require it during installing plugin for master? but there is no any message to remind me failure of installing plugin. anyway, I must run it behind proxy, how I set it on master?

Maple Wang gravatar imageMaple Wang ( 2015-11-08 05:41:26 -0600 )edit

set proxy only for yum? or set the system proxy like "export http_proxy"? is there any guide to remind user? thanks

Maple Wang gravatar imageMaple Wang ( 2015-11-08 05:42:12 -0600 )edit

The fuel Master and the Controller nodes need internet on the deployment phase, the other nodes, say Computes doesnt need internet access, but the Gateway of public IP should be pingable.

Bipin gravatar imageBipin ( 2015-11-09 03:11:13 -0600 )edit

thanks, I understand it now, but as I said, I must run my environment behind proxy, do you know how to set it to make fuel master and other nodes will use this proxy during deployment phase? besides, my proxy only handle the http request, do you know there is https request from fuel during deploy?

Maple Wang gravatar imageMaple Wang ( 2015-11-09 04:14:41 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-11-06 23:08:33 -0600

Seen: 240 times

Last updated: Nov 07 '15