Ask Your Question
0

Radware integration with Kilo

asked 2015-11-06 13:20:29 -0600

akshik gravatar image

Hi, i trying to integrate Radware with Kilo,

in using Fuel [MOS 7.0], i have enabled haproxy as one service provider, and its working fine

when trying to integrate Radware as second load balancer, im not getting it listed in service provider

neutron service-provider-list +--------------+---------+---------+ | service_type | name | default | +--------------+---------+---------+ | LOADBALANCER | haproxy | True | +--------------+---------+---------+

could not find any error in the log, and all agents are working fine

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-11-26 04:31:21 -0600

Hi Akshik ,

Which LBaaS Version are you using ? Is it LBaaS v1 or 2

  1. For V1 LBaaS - use pip install neutron_radware_lbaas
  2. For V2 - use pip install neutron_radware_lbaas_v2

when restarting neutron-server after Radware service provider is added, is the neutron agent-list showing services status as alive or dead .?

Also can you please confirm on which file you have enabled the service provider ? Is it neutron.conf or neutron-lbaas.conf?

For me the worked settings is given below for native LBaaS and Radware with HA, We are using LBaaS v1 driver implementation

LBaaS MOS 7 configuration :

Controllers

1.apt-get install neutron-lbaas-agent

2.vi /etc/openstack-dashboard/local_settings.py

' enable_lb': True,

3.vi /etc/neutron/neutron.conf

service_plugins =neutron.services.l3_router.l3_router_plugin.L3RouterPlugin,neutron.services.metering.metering_plugin.MeteringPlugin,lbaas

4.vi /etc/neutron/lbaas_agent.ini

debug = True interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver device_driver = neutron.services.loadbalancer.drivers.haproxy.namespace_driver.HaproxyNSDriver user_group = neutron

5.service neutron-server restart

6.service neutron-lbaas-agent restart

7.service apache2 restart

radware Driver installtion

1.pip install neutron_radware_lbaas

2.Go to /etc/neutron and edit the neutron.conf file as follows:

[radware]

vdirect_address="floating ip"

service_ha_pair="true"

3.Service provider addition in neutron-lbaas.conf

[service_providers]

service_provider=LOADBALANCER:Radware:neutron_lbaas.services.loadbalancer. drivers.radware.driver.LoadBalancerDriver:default

4.Restart neutron-server

Do let me know the result please

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-11-06 13:20:29 -0600

Seen: 124 times

Last updated: Nov 06 '15