Ask Your Question
0

Fuel PXE boot defaults to node "boot menu" with options for CENTOS and UBUNTU. However neither boots into a state that can be used by the master node. Can anyone help?

asked 2015-11-04 08:06:27 -0600

lvto2000 gravatar image

When attempting to set up a set of Dell 2950s nodes for use with a Fuel based install of openstack, all of them boot from the PXE then immediately default to a "boot menu"" screen. On that screen there is a very short timer that will automatically boot the original OS if I don't catch it. If I do catch it then I can select from what looks like CENTOS, UBUNTU and UBUNTU bootstrap images. None of the UBUNTU images work. When I select the CENTOS image it begins to boot then prompts me for the location of the install image after choosing the language.

After reading the fuel user guide and several developer websites I assumed that I needed to wait awhile to see if the node would show up on the dashboard. Its been over an hour and nothing. I have tried waiting on the "boot menu" stage and the post CENTOS selection stage. Nothing.

Can anyone help me understand what I am supposed to do next?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-11-04 23:51:19 -0600

Bipin gravatar image

Hi,

In the boot priority of server, you have to make the second option is boot from harddrive. It will be like as follow

(1) boot from PXE
(2) boot from HDD

No need to choose, either operating system manually. This is how it works, when a node is booted from fuel master via PXE, a boot strap image based on centos is installed in the node. Later, depends upon the environment you created, fuel will push the right operating system in to the nodes.

Regards

edit flag offensive delete link more

Comments

I think you missed my point. I have passed the point of selecting the PXE option. I am at the point where the PXE boot takes me into a boot menu based on contacting the Fuel Master after the PXE boot. That option does and should give me the option to select the bootstrap mode so the node boots

lvto2000 gravatar imagelvto2000 ( 2015-11-05 14:54:31 -0600 )edit

Let say a different way. The Fuel Master is built and ready. It has facilitated a boot of my new node based on the PXE option being selected in the node. The node then uses PXE then DHCP to boot into a "boot menu" screen where I can select the bootloader or other options. Nothing happens if sel.

lvto2000 gravatar imagelvto2000 ( 2015-11-05 14:58:44 -0600 )edit
0

answered 2015-11-06 10:01:20 -0600

lvto2000 gravatar image

The fix was to run the command fuel-bootstrap-image command. It rebuilt the bootloader then it was available on the boot menu screen. Selected that now it works for booting but my Master cannot see the nodes. The fuel version if this really is not good for my setup. Version 7 has been really really buggy for me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-11-04 08:06:27 -0600

Seen: 884 times

Last updated: Nov 06 '15